aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-m2crypto/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 08:12:41 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 08:12:41 -0300
commit90de19e96222fdf107dc89bde493c5a4889f2292 (patch)
tree75db175fe24508a31c5a5f3ea2192a7bc1d6116b /testing/py-m2crypto/APKBUILD
parent66a0a541d83acb73b22c9133a9c86175019b6f48 (diff)
downloadaports-90de19e96222fdf107dc89bde493c5a4889f2292.tar.bz2
aports-90de19e96222fdf107dc89bde493c5a4889f2292.tar.xz
testing/py3-m2crypto: rename from py-m2crypto
Diffstat (limited to 'testing/py-m2crypto/APKBUILD')
-rw-r--r--testing/py-m2crypto/APKBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/testing/py-m2crypto/APKBUILD b/testing/py-m2crypto/APKBUILD
deleted file mode 100644
index 002a9c8245..0000000000
--- a/testing/py-m2crypto/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-m2crypto
-_pkgname=M2Crypto
-pkgver=0.34.0
-pkgrel=0
-pkgdesc="A crypto and SSL toolkit for Python"
-url="https://pypi.python.org/pypi/M2Crypto/"
-arch="all"
-license="MIT"
-depends="py-typing"
-makedepends="python2-dev python3-dev py-setuptools openssl-dev swig"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- "
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ${python#python}"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-sha512sums="4d8f24fc2180f4acee1bb9d438e812fa0e96d1f68259efff1620ebc368f84d9ab86979ae38a746e982e83691a3dbe60fe63a33a7436eea0cba63364179d33d7f M2Crypto-0.34.0.tar.gz"