aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-m2crypto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-06 11:10:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:15 +0000
commit0b7d0b58844a112b949c1c12ef2b2b8c5dba7b03 (patch)
tree2b755a3e6daca195d990d55d2e571932c406f090 /testing/py-m2crypto
parentd4a1d06fdf97d2b051f31997cbee347c4d444c8a (diff)
downloadaports-0b7d0b58844a112b949c1c12ef2b2b8c5dba7b03.tar.bz2
aports-0b7d0b58844a112b949c1c12ef2b2b8c5dba7b03.tar.xz
testing/py-m2crypto: rebuild against openssl 1.1
Diffstat (limited to 'testing/py-m2crypto')
-rw-r--r--testing/py-m2crypto/APKBUILD8
-rw-r--r--testing/py-m2crypto/libressl.patch24
-rw-r--r--testing/py-m2crypto/m2crypto-0.30.1-gcc_macros.patch23
3 files changed, 26 insertions, 29 deletions
diff --git a/testing/py-m2crypto/APKBUILD b/testing/py-m2crypto/APKBUILD
index 9c2354a43e..c477552027 100644
--- a/testing/py-m2crypto/APKBUILD
+++ b/testing/py-m2crypto/APKBUILD
@@ -3,16 +3,15 @@
pkgname=py-m2crypto
_pkgname=M2Crypto
pkgver=0.30.1
-pkgrel=0
+pkgrel=1
pkgdesc="A crypto and SSL toolkit for Python"
url="https://pypi.python.org/pypi/M2Crypto/"
arch="all"
license="BSD"
depends="py-typing"
-makedepends="python2-dev python3-dev py-setuptools libressl-dev swig"
+makedepends="python2-dev python3-dev py-setuptools openssl-dev swig"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- libressl.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -46,5 +45,4 @@ _py3() {
_py python3
}
-sha512sums="c85b6350d8b6b4a14e9c76b755cdc1a88d7ba63ae75ebfbb32d42389225c0a3cf9d530f95c2651ff3811c755cd9bbb482f81fdb0dcf670d7a0015320622725b2 M2Crypto-0.30.1.tar.gz
-a95d7c1bd3b3bfa336ef97777e6ddde7ce3f2ccc7356bbd6285ddf614eec5cdb6097ee44e36d0fa3996bee29f6a642c6abd707c5b76ce6ed55ccd667ac470ddb libressl.patch"
+sha512sums="c85b6350d8b6b4a14e9c76b755cdc1a88d7ba63ae75ebfbb32d42389225c0a3cf9d530f95c2651ff3811c755cd9bbb482f81fdb0dcf670d7a0015320622725b2 M2Crypto-0.30.1.tar.gz"
diff --git a/testing/py-m2crypto/libressl.patch b/testing/py-m2crypto/libressl.patch
deleted file mode 100644
index b564c2bbc7..0000000000
--- a/testing/py-m2crypto/libressl.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/SWIG/_bio.i
-+++ b/SWIG/_bio.i
-@@ -9,6 +9,10 @@
-
- %{
- #include <openssl/bio.h>
-+
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#define BIO_get_init(b) (b)->init
-+#endif
- %}
-
- %apply Pointer NONNULL { BIO * };
---- a/SWIG/_lib11_compat.i
-+++ b/SWIG/_lib11_compat.i
-@@ -8,7 +8,7 @@
- */
-
- %{
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-
- #include <string.h>
- #include <openssl/engine.h>
diff --git a/testing/py-m2crypto/m2crypto-0.30.1-gcc_macros.patch b/testing/py-m2crypto/m2crypto-0.30.1-gcc_macros.patch
new file mode 100644
index 0000000000..a31e86e302
--- /dev/null
+++ b/testing/py-m2crypto/m2crypto-0.30.1-gcc_macros.patch
@@ -0,0 +1,23 @@
+diff -up M2Crypto-0.30.1/SWIG/_m2crypto.i.gcc_macros M2Crypto-0.30.1/SWIG/_m2crypto.i
+--- M2Crypto-0.30.1/SWIG/_m2crypto.i.gcc_macros 2018-02-24 14:54:59.000000000 +0100
++++ M2Crypto-0.30.1/SWIG/_m2crypto.i 2018-05-19 06:07:31.032986837 +0200
+@@ -7,6 +7,7 @@
+ * Copyright (c) 2009-2010 Heikki Toivonen. All rights reserved.
+ *
+ */
++%import "gcc_macros.h"
+
+ %module(threads=1) m2crypto
+ /* We really don't need threadblock (PyGILState_Ensure() etc.) anywhere.
+@@ -15,11 +16,6 @@
+ %nothreadblock;
+ %nothreadallow;
+
+-#if SWIG_VERSION >= 0x030000
+-#define __WCHAR_MAX__ __WCHAR_MAX
+-#define __WCHAR_MIN__ __WCHAR_MIN
+-#endif
+-
+ %{
+ #ifdef _WIN32
+ #define _WINSOCKAPI_