aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pandas
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-02-25 14:04:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-02-25 14:04:10 +0000
commiteaf19f88756e63006252a9d72a4e1af3ae4613e4 (patch)
treecaef369602cf0b944fc7a69d8d286680ca0bef12 /testing/py-pandas
parent70b3b18877a66cddb26ca51dbae977e677696811 (diff)
downloadaports-eaf19f88756e63006252a9d72a4e1af3ae4613e4.tar.bz2
aports-eaf19f88756e63006252a9d72a4e1af3ae4613e4.tar.xz
Revert "testing/py-pandas new aport"
Package does not create the expected subpackages which results that builders rebuilds it every time. This reverts commit ba2edb737ba9d1243a046560d852e3ebc1defe2d.
Diffstat (limited to 'testing/py-pandas')
-rw-r--r--testing/py-pandas/APKBUILD50
1 files changed, 0 insertions, 50 deletions
diff --git a/testing/py-pandas/APKBUILD b/testing/py-pandas/APKBUILD
deleted file mode 100644
index 5018806930..0000000000
--- a/testing/py-pandas/APKBUILD
+++ /dev/null
@@ -1,50 +0,0 @@
-# Contributor: Sasha Gerrand <alpine-pkgs@sgerrand.com>
-# Maintainer: Sasha Gerrand <alpine-pkgs@sgerrand.com>
-pkgname=py-pandas
-_pkgname=pandas
-pkgver=0.23.4
-pkgrel=0
-pkgdesc="Powerful data structures for data analysis, time series, and statistics"
-url="http://pandas.pydata.org/"
-arch="noarch"
-license="BSD"
-depends="python py-dateutil py-numpy py-tz"
-makedepends="linux-headers py-numpy-dev py-setuptools python2-dev python3-dev"
-install=""
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ${python#python}"
- depends="$depends $python"
- subpkgarch="all"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-sha512sums="0c89db820a49e0cfb9764e64589ff9af819f9a53c01bd0254cd1b6dbd1e9fd452b2ff7c7330ede7623c7576589113e831a19a57c735562b55f90506df15805b9 pandas-0.23.4.tar.gz" \ No newline at end of file