aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-protobuf
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-21 01:25:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-21 14:23:07 -0300
commiteca93ea0d94ddf0a695838303bd6d12712fb78f6 (patch)
treeb385c8f12ceeebc125bf873d9dddbe03b207663e /testing/py-protobuf
parentcdb22c5fbae071527eab9332e3995a3efc0a826f (diff)
downloadaports-eca93ea0d94ddf0a695838303bd6d12712fb78f6.tar.bz2
aports-eca93ea0d94ddf0a695838303bd6d12712fb78f6.tar.xz
testing/py3-protobuf: rename from py-protobuf
Diffstat (limited to 'testing/py-protobuf')
-rw-r--r--testing/py-protobuf/APKBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/testing/py-protobuf/APKBUILD b/testing/py-protobuf/APKBUILD
deleted file mode 100644
index 96b1443fd7..0000000000
--- a/testing/py-protobuf/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Maintainer: Corentin Henry <corentinhenry@gmail.com>
-# Contributor: Corentin Henry <corentinhenry@gmail.com>
-pkgname=py-protobuf
-_pkgname=${pkgname#py-}
-pkgver=3.8.0
-pkgrel=0
-pkgdesc="Google's data interchange format."
-url="https://github.com/google/protobuf"
-arch="noarch"
-license="BSD-3-Clause"
-depends="py-six>=1.9"
-makedepends="protobuf py-setuptools py3-setuptools py-google-apputils"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-# NOTE: Always use releases of protobuf, not pypi or auto-generated GitHub
-# tarballs as they do not contain the necessary componenets to run tests.
-source="https://github.com/protocolbuffers/protobuf/releases/download/v$pkgver/protobuf-python-$pkgver.tar.gz"
-builddir="$srcdir"/protobuf-$pkgver/python
-
-build() {
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-check() {
- python3 setup.py test
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
- # correct permissions
- chmod +r "$subpkgdir"/usr/lib/*/site-packages/*/*
-}
-
-sha512sums="7ef725ad70d91154c69ffabfa3d292abdd477cf5be97ebcee8404f1b4354a5620108169e2e2c48fdacd09ea5e73957f30c1bcfd98d01c84916a6f7b416a4b9a5 protobuf-python-3.8.0.tar.gz"