aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pylast
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-08 21:16:44 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-08 21:16:52 +0200
commit42a3a280604219b826afe5f0782685a90ea70769 (patch)
tree3ff83ba58f45c435119fbcb53bb7cf1b47eb180a /testing/py-pylast
parentd8d21369292a49efa5140d2674e5d87fc25ed2bb (diff)
downloadaports-42a3a280604219b826afe5f0782685a90ea70769.tar.bz2
aports-42a3a280604219b826afe5f0782685a90ea70769.tar.xz
testing/py-pylast: new aport
Diffstat (limited to 'testing/py-pylast')
-rw-r--r--testing/py-pylast/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-pylast/APKBUILD b/testing/py-pylast/APKBUILD
new file mode 100644
index 0000000000..22b5efadb6
--- /dev/null
+++ b/testing/py-pylast/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-pylast
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A Python interface to the last.fm API"
+url="https://github.com/pylast/pylast"
+arch="noarch"
+license="Apache"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/p/pylast/pylast-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pylast-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a8404fee22b55352c9da25d6fa55c38c pylast-1.0.0.tar.gz"
+sha256sums="948bc9efb2e2785db8c303cc6559358b943538cc45f902838db770b84843d605 pylast-1.0.0.tar.gz"
+sha512sums="1d6183596ff994f37722be493e22c65a2c441f5890b539fd9e19d515a5a38afc7017524600903879a8c76b938a52dec6ef4753c0e01dd59bae4e1596962755a0 pylast-1.0.0.tar.gz"