aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-rpi-gpio
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-06 19:34:49 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-07-08 17:39:12 +0200
commitbb62c4901b5dcda2d798b25d48d8bcb55868c5f0 (patch)
treec783b9439643f213427145d274292e69bd6b8c4d /testing/py-rpi-gpio
parentd7037afe2ba42041d38abdfcfe59185f54ca341a (diff)
downloadaports-bb62c4901b5dcda2d798b25d48d8bcb55868c5f0.tar.bz2
aports-bb62c4901b5dcda2d798b25d48d8bcb55868c5f0.tar.xz
testing/*: change source URL pypi.python.org to files.pythonhosted.org
See https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package#comment-27734791
Diffstat (limited to 'testing/py-rpi-gpio')
-rw-r--r--testing/py-rpi-gpio/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/py-rpi-gpio/APKBUILD b/testing/py-rpi-gpio/APKBUILD
index 71856725b5..cb8e332303 100644
--- a/testing/py-rpi-gpio/APKBUILD
+++ b/testing/py-rpi-gpio/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Justin Saunders <justin@jumaka.co.uk>
# Maintainer: Justin Saunders <justin@jumaka.co.uk>
pkgname=py-rpi-gpio
-_pkg_real=RPi.GPIO
+_pkgname=RPi.GPIO
pkgver=0.6.1
pkgrel=0
pkgdesc="A python module to control Raspberry Pi GPIO channels"
@@ -12,9 +12,9 @@ pydepends=""
pymakedepends=""
depends="python $pydepends"
makedepends="python-dev $pymakedepends"
-source="https://pypi.python.org/packages/source/R/RPi.GPIO/RPi.GPIO-0.6.1.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkg_real-$pkgver"
+_builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$_builddir"
python setup.py build || return 1