aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-rpi-gpio
diff options
context:
space:
mode:
authorJustin Saunders <justin@jumaka.co.uk>2016-02-22 21:09:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-02-23 06:10:03 +0000
commitdfed446838983c0cc96472472838213405baf12f (patch)
treec4897ca4809c8f1cc96d510d18e3e0cf868d03e4 /testing/py-rpi-gpio
parent9389c2d174270bef96cb48c0e5c79ef5a60b2288 (diff)
downloadaports-dfed446838983c0cc96472472838213405baf12f.tar.bz2
aports-dfed446838983c0cc96472472838213405baf12f.tar.xz
testing/py-rpi-gpio
https://pypi.python.org/pypi/RPi.GPIO A python module to control Raspberry Pi GPIO channels
Diffstat (limited to 'testing/py-rpi-gpio')
-rw-r--r--testing/py-rpi-gpio/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py-rpi-gpio/APKBUILD b/testing/py-rpi-gpio/APKBUILD
new file mode 100644
index 0000000000..71856725b5
--- /dev/null
+++ b/testing/py-rpi-gpio/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Justin Saunders <justin@jumaka.co.uk>
+# Maintainer: Justin Saunders <justin@jumaka.co.uk>
+pkgname=py-rpi-gpio
+_pkg_real=RPi.GPIO
+pkgver=0.6.1
+pkgrel=0
+pkgdesc="A python module to control Raspberry Pi GPIO channels"
+url="https://pypi.python.org/pypi/RPi.GPIO"
+arch="armhf"
+license="PSF"
+pydepends=""
+pymakedepends=""
+depends="python $pydepends"
+makedepends="python-dev $pymakedepends"
+source="https://pypi.python.org/packages/source/R/RPi.GPIO/RPi.GPIO-0.6.1.tar.gz"
+
+_builddir="$srcdir/$_pkg_real-$pkgver"
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir" \
+ || return 1
+}
+md5sums="254d0443a436eb241367c487274e7197 RPi.GPIO-0.6.1.tar.gz"
+sha256sums="54e5fb06d9ea1a1389a497fb5a06dfa950c86303b0f4ba89b68c55999d1df064 RPi.GPIO-0.6.1.tar.gz"
+sha512sums="8a66a5c6283b79aa6cc5bbf16507c6c93ba6c53b84b6b67d2f133572ce76cb2c8ba4b0957a4fc131ff920e0b34b09aa913d0c9401dc1bfaf76be8235b4f33687 RPi.GPIO-0.6.1.tar.gz"