aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-setproctitle
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-12 22:05:42 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-06-12 22:06:40 +0200
commit334df784d9f221aaaad97b77f1ed6f623de41836 (patch)
tree955faaa88d36f0c99d8accc19d68ffed1dbf1956 /testing/py-setproctitle
parenta82871c15f42426b4d86d73f499fe8a0b49ff255 (diff)
downloadaports-334df784d9f221aaaad97b77f1ed6f623de41836.tar.bz2
aports-334df784d9f221aaaad97b77f1ed6f623de41836.tar.xz
testing/py-setproctitle: upgrade to 1.1.10 and improve abuild
Diffstat (limited to 'testing/py-setproctitle')
-rw-r--r--testing/py-setproctitle/APKBUILD36
-rw-r--r--testing/py-setproctitle/spt_status.c.patch10
2 files changed, 11 insertions, 35 deletions
diff --git a/testing/py-setproctitle/APKBUILD b/testing/py-setproctitle/APKBUILD
index 09f760b396..532da3191d 100644
--- a/testing/py-setproctitle/APKBUILD
+++ b/testing/py-setproctitle/APKBUILD
@@ -1,41 +1,27 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py-setproctitle
-_pkgname=${pkgname/py-/}
-pkgver="1.1.9"
+pkgver=1.1.10
pkgrel=0
pkgdesc="A Python module to customize the process title."
url="https://github.com/dvarrazzo/py-setproctitle"
arch="all"
license="BSD"
-depends="python"
-depends_dev=""
+depends=""
makedepends="python-dev musl-dev"
-install=""
-subpackages=""
-source="https://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- spt_status.c.patch
- "
-
-_builddir="$srcdir/$_pkgname-$pkgver"
-prepare() {
- cd "$_builddir"
- patch -p1 -i "$srcdir"/spt_status.c.patch || return 1
-}
+source="$pkgname-$pkgver.tar.gz::https://github.com/dvarrazzo/$pkgname/archive/version-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-version-$pkgver"
build() {
- cd "$_builddir"
- python setup.py build || return 1
+ cd "$builddir"
+ python setup.py build
}
package() {
- cd "$_builddir"
- python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="95d9e56c69437246460a20804961d70d setproctitle-1.1.9.tar.gz
-175429a592de14170499d303a866a2d1 spt_status.c.patch"
-sha256sums="1c3414d18f9cacdab78b0ffd8e886d56ad45f22e55001a72aaa0b2aeb56a0ad7 setproctitle-1.1.9.tar.gz
-6ccc0f3ddbcd5faba5ec8e2b7de88dccd31b04a1797c3ae0454c00ff3c07f839 spt_status.c.patch"
-sha512sums="f5640543105dd039192378983b098e0eca643b5eee314a18886aef0d13674e1ea74f753bfb33582f51a6fb34f9c3d0831764bc099dec9b9e14fe12e7446d30f1 setproctitle-1.1.9.tar.gz
-e15997f0d535801d0aff1ca403a314463892baca06ff1d5ceba2f9f52080016b1945cfa731c4ae4de3fde0649f44ae34ccc40478ef005c8a49d0037382877d4f spt_status.c.patch"
+md5sums="bc3ab23d326b5cdc8ca0a1d45b422ae4 py-setproctitle-1.1.10.tar.gz"
+sha256sums="1c3a8f60b90bbe1d7987597c1ef637ecfbc8f4bb2a5500c36fb232ea7bedf925 py-setproctitle-1.1.10.tar.gz"
+sha512sums="987729fd4f6b1f6ca1bead0814a2917eee4a30b01cdd8c3f0d028c4f925f1d1eff2ee2fe3945a2770d9cc7a6f2e74059db21dc8cd112d66304bd481fd287da23 py-setproctitle-1.1.10.tar.gz"
diff --git a/testing/py-setproctitle/spt_status.c.patch b/testing/py-setproctitle/spt_status.c.patch
deleted file mode 100644
index 733e30adfb..0000000000
--- a/testing/py-setproctitle/spt_status.c.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/spt_status.c
-+++ b/src/spt_status.c
-@@ -55,7 +55,6 @@
- #endif
- #ifdef HAVE_SYS_PRCTL_H
- #include <sys/prctl.h> /* for Linux >= 2.6.9 */
--#include <linux/prctl.h>
- #endif
- #if defined(__darwin__)
- #include <crt_externs.h>