aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-simplegeneric
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-15 17:01:44 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-09-17 06:36:13 +0000
commit5c547c54a6e77fe662e956275c9af234c3fa024a (patch)
tree3752ff55de8ad87cb2614d003383f3cbfdeafd0b /testing/py-simplegeneric
parentc2b1920875df9a97ab4ad94d29b5501590495fb3 (diff)
downloadaports-5c547c54a6e77fe662e956275c9af234c3fa024a.tar.bz2
aports-5c547c54a6e77fe662e956275c9af234c3fa024a.tar.xz
testing/py-simplegeneric: new aport
dependency for ipython
Diffstat (limited to 'testing/py-simplegeneric')
-rw-r--r--testing/py-simplegeneric/APKBUILD53
-rw-r--r--testing/py-simplegeneric/remove-setup-warning.patch12
2 files changed, 65 insertions, 0 deletions
diff --git a/testing/py-simplegeneric/APKBUILD b/testing/py-simplegeneric/APKBUILD
new file mode 100644
index 0000000000..3047f895e3
--- /dev/null
+++ b/testing/py-simplegeneric/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py-simplegeneric
+pkgver=0.8.1
+pkgrel=0
+pkgdesc="Simple generic functions"
+url="https://pypi.org/project/simplegeneric/"
+arch="noarch"
+license="ZPL-2.1"
+makedepends="python2-dev python3-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/s/simplegeneric/simplegeneric-$pkgver.zip
+ remove-setup-warning.patch"
+builddir="$srcdir/${pkgname#py-}-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python2 simplegeneric.py
+ python3 simplegeneric.py
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="74c25d4e04fe197058cb43fabe3702cc5901989dc0b0bcf7511369f4f3d90fd98e4225174db0680c8f39389914f82824bdbdaf4c302b53998fbabbf0dba393e4 simplegeneric-0.8.1.zip
+8558e711659fc2bc76cf8a770a0950778fa7d0b11165fdca0ac444575de3efdd3ae5bdc37351ce532b6d9245eee9e06fe8c614e23f3db709e5a53debe424e4fd remove-setup-warning.patch"
diff --git a/testing/py-simplegeneric/remove-setup-warning.patch b/testing/py-simplegeneric/remove-setup-warning.patch
new file mode 100644
index 0000000000..cbb4c7a692
--- /dev/null
+++ b/testing/py-simplegeneric/remove-setup-warning.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py.new
+index 0fd974742f..4a42241d37 100644
+--- a/setup.py
++++ b/setup.py.new
+@@ -33,7 +33,6 @@ setup(
+ author="Phillip J. Eby",
+ author_email="peak@eby-sarna.com",
+ license="ZPL 2.1",
+- test_suite = 'simplegeneric.test_suite',
+ py_modules = ['simplegeneric'],
+ classifiers = [
+ line.strip() for line in open('classifiers.txt') if line.strip()