aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinxcontrib-cheeseshop
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-10 09:43:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:52 +0000
commit7026824187028cf5c1a184c236f18e020aa26e57 (patch)
treed9c5561b359d47ab4425fd7aac85cd3c4db343e6 /testing/py-sphinxcontrib-cheeseshop
parent909cbae3fe4f1249c1eddd3b1e7ee90e0ae6647d (diff)
downloadaports-7026824187028cf5c1a184c236f18e020aa26e57.tar.bz2
aports-7026824187028cf5c1a184c236f18e020aa26e57.tar.xz
testing/py-sphinxcontrib-cheeseshop: new aport
Sphinx cheeseshop extension https://pypi.python.org/pypi/sphinxcontrib-cheeseshop
Diffstat (limited to 'testing/py-sphinxcontrib-cheeseshop')
-rw-r--r--testing/py-sphinxcontrib-cheeseshop/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinxcontrib-cheeseshop/APKBUILD b/testing/py-sphinxcontrib-cheeseshop/APKBUILD
new file mode 100644
index 0000000000..8f80379a85
--- /dev/null
+++ b/testing/py-sphinxcontrib-cheeseshop/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-cheeseshop
+_pkgname=sphinxcontrib-cheeseshop
+pkgver=0.2
+pkgrel=0
+pkgdesc="Sphinx cheeseshop extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-cheeseshop"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="56aff09d56d3e75236c024fcfe6ffa01 sphinxcontrib-cheeseshop-0.2.tar.gz"
+sha256sums="d1a3bc4c1842868f959f7e14fa7390e64fa717823144286e7d15a25c3624b1ec sphinxcontrib-cheeseshop-0.2.tar.gz"
+sha512sums="5d6c88c0c43f37b94ebe6a2a62f795a6f7d5d6c407b808d6b21d54c1775fc4b5f22466c13e61adc16ac7973ba11e99a66da8650c869856f766e6bb3a6e99923b sphinxcontrib-cheeseshop-0.2.tar.gz"