aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinxcontrib-cldomain
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-17 18:57:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:53 +0000
commitd3f3e554fb8961fcf0e08524ffd30c721061c0a1 (patch)
treeb878d7ba189379b9936d89da2eb620cd80a60fd1 /testing/py-sphinxcontrib-cldomain
parent09dba2166dfa70ac0e94e80aa925814ebf5cbb9b (diff)
downloadaports-d3f3e554fb8961fcf0e08524ffd30c721061c0a1.tar.bz2
aports-d3f3e554fb8961fcf0e08524ffd30c721061c0a1.tar.xz
testing/py-sphinxcontrib-cldomain: new aport
Sphinx cldomain extension https://pypi.python.org/pypi/sphinxcontrib-cldomain
Diffstat (limited to 'testing/py-sphinxcontrib-cldomain')
-rw-r--r--testing/py-sphinxcontrib-cldomain/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinxcontrib-cldomain/APKBUILD b/testing/py-sphinxcontrib-cldomain/APKBUILD
new file mode 100644
index 0000000000..3e26416694
--- /dev/null
+++ b/testing/py-sphinxcontrib-cldomain/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-cldomain
+_pkgname=sphinxcontrib-cldomain
+pkgver=0.7
+pkgrel=0
+pkgdesc="Sphinx cldomain extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-cldomain"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f6c79668eb575e0dc2b41dff7de3d28f sphinxcontrib-cldomain-0.7.tar.gz"
+sha256sums="fab5288a1327131caa8ef11e1dc38b6827c367bff4aac0b00f7632a02041eef1 sphinxcontrib-cldomain-0.7.tar.gz"
+sha512sums="53532be59d3b9af3fb9fdd89a361a4702e57c8e7e0667c0b53c7c6731357616ff6e28e5af2759de9778b3a9d4eb3df356374bd50520d4ffb20808adf300d7561 sphinxcontrib-cldomain-0.7.tar.gz"