aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-tkinter/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-26 12:59:33 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-26 14:36:25 +0200
commitf05966bfdabd2377d492cf821d388bbae89c230d (patch)
tree4775d2daf50a45057ea42b440a6b4a04f137c620 /testing/py-tkinter/APKBUILD
parent4be45f38c045321c399290136396ac3c2a48af3d (diff)
downloadaports-f05966bfdabd2377d492cf821d388bbae89c230d.tar.bz2
aports-f05966bfdabd2377d492cf821d388bbae89c230d.tar.xz
testing/py-tkinter: remove, replaced by py2-tkinter from main/python2
Diffstat (limited to 'testing/py-tkinter/APKBUILD')
-rw-r--r--testing/py-tkinter/APKBUILD87
1 files changed, 0 insertions, 87 deletions
diff --git a/testing/py-tkinter/APKBUILD b/testing/py-tkinter/APKBUILD
deleted file mode 100644
index 1effa6fc70..0000000000
--- a/testing/py-tkinter/APKBUILD
+++ /dev/null
@@ -1,87 +0,0 @@
-# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
-# This depends on the current packaging of Python,
-# which includes idle, the tkinter and idle *.py* files, but not _tkinter.so
-pkgname=py-tkinter
-_pkgname=python
-pkgver=2.7.9
-_verbase=${pkgver%.*}
-pkgrel=0
-pkgdesc="Tk interface for Python"
-url="http://www.python.org"
-arch="all"
-license="custom"
-subpackages=""
-depends=""
-makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev
- libffi-dev tk-dev python-dev"
-source="http://www.$pkgname.org/ftp/$_pkgname/$pkgver/Python-$pkgver.tar.xz
- find_library.patch
- unchecked-ioctl.patch
- "
-
-prepare() {
- cd "$srcdir/Python-$pkgver"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1
- esac
- done
-
- # verify that python version corresponds with system python version
- _pyver=$(python -c 'import platform; print platform.python_version()')
- if [ "$_pyver" != "$pkgver" ]; then
- error "$pkgver does not correspond with python $_pyver"
- return 1
- fi
-
- # Make sure we use system libs
- rm -r Modules/expat Modules/_ctypes/libffi* Modules/zlib || return 1
-
- # make sure our /dev/shm is world writeable
- if ! touch /dev/shm/"$pkgname-$pkgver"; then
- error "/dev/shm is not world writeable. this will cause a broken python build"
- return 1
- fi
- rm /dev/shm/"$pkgname-$pkgver"
-}
-
-build() {
- cd "$srcdir/Python-$pkgver"
- export OPT="$CFLAGS"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --enable-shared \
- --with-threads \
- --enable-ipv6 \
- --with-system-ffi \
- --with-system-expat \
- --with-system-zlib \
- --enable-unicode=ucs4 \
- --with-tcltk-libs="`pkg-config --libs tk`" \
- --with-tcltk-includes="`pkg-config --cflags tk`" \
- || return 1
- make sharedmods || return 1
-}
-
-package() {
- cd "$srcdir/Python-$pkgver"
- make -j1 DESTDIR="$pkgdir" sharedinstall || return 1
- find "$pkgdir/" -type f ! -name _tkinter.so -exec rm -f '{}' + \
- || return 1
- find "$pkgdir/" -type l -exec rm -f '{}' + || return 1
- find "$pkgdir/" -type d -exec rmdir -p '{}' \; || true
- ls "$pkgdir/usr/lib/$_pkgname$_verbase/lib-dynload/_tkinter.so" \
- || return 1
-}
-
-md5sums="38d530f7efc373d64a8fb1637e3baaa7 Python-2.7.9.tar.xz
-5d8ca92fa6f187573104593470a9d3d5 find_library.patch
-dada786a50fa332686a9b9260d84c110 unchecked-ioctl.patch"
-sha256sums="90d27e14ea7e03570026850e2e50ba71ad20b7eb31035aada1cf3def8f8d4916 Python-2.7.9.tar.xz
-63b2b1489c2b97b450bb2d19b64f2ae6cca5c43d549c131c7807fbe52b7bbf21 find_library.patch
-f9d37609bab83d9ffff96ec9a33e16568cfb14980d389f7fe34a1c837397e359 unchecked-ioctl.patch"
-sha512sums="6939182463272a6bb9da0e327bfb9efc574a87820f2ae39eaf02d9fae053dbe0004330e916e6828becfef94cbe294acb0a88a600f8930b99b94fcfc4efc44ff4 Python-2.7.9.tar.xz
-cbb18c23b1b55025ba8a08debd545b68317eef2732f9f631d2629ed71b603b9a90843bca5df9db7072e83e29c928b0e9c557d0710955692052607db36a241c08 find_library.patch
-5a8e013a4132d71c4360771f130d27b37275ae59330cf9a75378dc8a11236017f540eb224f2a148984e82ca3fb6b29129375b1080ba05b81044faa717520ab82 unchecked-ioctl.patch"