aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-tornado
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2014-08-24 01:38:02 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-04 08:53:14 +0000
commitc6662360f07044122defa023a57b23535e1d3c74 (patch)
tree8bdf9a1241a6c18f7760e437bbde82594f67cb79 /testing/py-tornado
parentda75ba53c10e2a6b3515a87f9b19c9e44235e1bd (diff)
downloadaports-c6662360f07044122defa023a57b23535e1d3c74.tar.bz2
aports-c6662360f07044122defa023a57b23535e1d3c74.tar.xz
testing/py-tornado: new aport
http://www.tornadoweb.org/ Python web framework and asynchronous networking library
Diffstat (limited to 'testing/py-tornado')
-rw-r--r--testing/py-tornado/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-tornado/APKBUILD b/testing/py-tornado/APKBUILD
new file mode 100644
index 0000000000..3abded32f9
--- /dev/null
+++ b/testing/py-tornado/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer:
+pkgname=py-tornado
+_pkgname=tornado
+pkgver=4.0.1
+pkgrel=0
+pkgdesc="Python web framework and asynchronous networking library"
+url="http://www.tornadoweb.org/"
+arch="noarch"
+license="Apache"
+depends="python py-backports.ssl_match_hostname py-certifi"
+depends_dev="py-setuptools"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 || return 1
+}
+
+md5sums="2b28e37b95aa653369a31a440242a24a tornado-4.0.1.tar.gz"
+sha256sums="ae058668b276b1ec7383cfc911323e6d27b3b47e38a12d3d3eaf6b6577b99901 tornado-4.0.1.tar.gz"
+sha512sums="a4e0231e77ebbc2885bab648b292b842cb15c84d66a1972de18cb00fcc611eae2794b872f070ab7d5af32dd0c6c1773527fe1332bd382c1821e1f2d5d76808fb tornado-4.0.1.tar.gz"