aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-tqdm
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-01-06 20:11:36 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 15:12:39 +0000
commitdbb7f3f5ffbeddaa7db286690aa338912b933ef4 (patch)
tree08d82350f32ca547393214a58093c68285f1af56 /testing/py-tqdm
parentf5c5ca83a9dac89ee81cff2b81556b2fec6ea4ca (diff)
downloadaports-dbb7f3f5ffbeddaa7db286690aa338912b933ef4.tar.bz2
aports-dbb7f3f5ffbeddaa7db286690aa338912b933ef4.tar.xz
testing/tqdm: update to 4.29.0
Diffstat (limited to 'testing/py-tqdm')
-rw-r--r--testing/py-tqdm/0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch36
-rw-r--r--testing/py-tqdm/APKBUILD12
2 files changed, 18 insertions, 30 deletions
diff --git a/testing/py-tqdm/0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch b/testing/py-tqdm/0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch
index 55f62a0f90..2018fa0392 100644
--- a/testing/py-tqdm/0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch
+++ b/testing/py-tqdm/0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch
@@ -1,40 +1,32 @@
-From e54e652c04153fdad6949fee2c659ea4330bb294 Mon Sep 17 00:00:00 2001
+From 87da1f29923cf7f1af65f8b8a26c155545b61073 Mon Sep 17 00:00:00 2001
From: Drew DeVault <sir@cmpwn.com>
-Date: Fri, 22 Dec 2017 11:36:04 -0800
+Date: Tue, 1 Jan 2019 20:40:05 -0500
Subject: [PATCH] Skip flaky test that depends on GNU coreutils
---
- tqdm/tests/tests_main.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
+ tqdm/tests/tests_main.py | 2 ++
+ 1 file changed, 2 insertions(+)
diff --git a/tqdm/tests/tests_main.py b/tqdm/tests/tests_main.py
-index 32dc820..93b4181 100644
+index 58fbbd3..3fad869 100644
--- a/tqdm/tests/tests_main.py
+++ b/tqdm/tests/tests_main.py
-@@ -1,6 +1,7 @@
- import sys
- import subprocess
+@@ -4,6 +4,7 @@ from os import path
+ from shutil import rmtree
+ from tempfile import mkdtemp
from tqdm import main, TqdmKeyError, TqdmTypeError
+from nose.plugins.skip import SkipTest
- from tests_tqdm import with_setup, pretest, posttest, _range, closing, UnicodeIO
-
-@@ -14,6 +15,7 @@ def _sh(*cmd, **kwargs):
+ from tests_tqdm import with_setup, pretest, posttest, _range, closing, \
+ UnicodeIO, StringIO
+@@ -17,6 +18,7 @@ def _sh(*cmd, **kwargs):
+ # WARNING: this should be the last test as it messes with sys.stdin, argv
@with_setup(pretest, posttest)
def test_main():
- """Test command line pipes"""
+ raise SkipTest
+ """Test command line pipes"""
ls_out = _sh('ls').replace('\r\n', '\n')
ls = subprocess.Popen('ls', stdout=subprocess.PIPE,
- stderr=subprocess.STDOUT)
-@@ -22,7 +24,6 @@ def test_main():
- ls.wait()
-
- # actual test:
--
- assert (ls_out in res.replace('\r\n', '\n'))
-
- # semi-fake test which gets coverage:
--
-2.15.0
+2.20.1
diff --git a/testing/py-tqdm/APKBUILD b/testing/py-tqdm/APKBUILD
index 819b425325..4dbb33d72a 100644
--- a/testing/py-tqdm/APKBUILD
+++ b/testing/py-tqdm/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py-tqdm
_pkgname=tqdm
-pkgver=4.19.5
+pkgver=4.29.0
pkgrel=1
pkgdesc="Fast, Extensible Progress Meter"
url="https://pypi.python.org/pypi/tqdm"
@@ -10,8 +10,7 @@ license="MIT"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- 0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch
- 0001-Import-sleep-nearer-to-usage.patch"
+0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch"
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
@@ -57,8 +56,6 @@ _py() {
# Add version suffix to executable.
mv usr/bin/tqdm usr/bin/tqdm-$pyver
-
- rm -r usr/man
}
_py2() {
@@ -69,6 +66,5 @@ _py3() {
_py python3
}
-sha512sums="fff1946466e109bf020a6dbaca7e99b992c0335bc4b380224e981b2e0690a5ef465fdd95ee9473bdc0f0381897c5314cee715c600708d02892e0a109e5b9dbbe tqdm-4.19.5.tar.gz
-3e94642970da68ec422f78ba8aa080832ab3b2d2cb66b137d79dccd71921d0bb8796f97828b1eedd5751502a816bbd6a6d66fae238bd9a6fbc46c58f93d69636 0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch
-4d6b06028a8d8c4214dc57168fa50ccd19fea79b7099d5d695bf00a6e8f01ece76341dc992ce8bfb513140f3b425d29e428842a8ade417d758bf4c67474d65d0 0001-Import-sleep-nearer-to-usage.patch"
+sha512sums="1b4cb95d5bc8dbbf48530a7ab66395a77813350780f48228ad858831ce017993643978a2582b093ab15574d39c054f76ff9bc0ebd1391607be62b4913e83c3e3 tqdm-4.29.0.tar.gz
+227b39f92ef529762c455d6cb82a84f05af00a7d72b505082a749c1de959ab7814ef0b3b07df62c77ebc184671f5579718f000eaafa534b775b58427de935e96 0001-Skip-flaky-test-that-depends-on-GNU-coreutils.patch"