aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-urlobject
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-02 21:40:12 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-04 20:55:02 +0000
commit593eb773fb1d090826b28e83dbac59574829cfb8 (patch)
treed2646e678e000fdb701fe533c09502e003fa1114 /testing/py-urlobject
parentcb1bb3fa357a5613c11dadbb7f7fda23f8ca9294 (diff)
downloadaports-593eb773fb1d090826b28e83dbac59574829cfb8.tar.bz2
aports-593eb773fb1d090826b28e83dbac59574829cfb8.tar.xz
testing/py-urlobject: modernize
- Enable check - Use modern style - Lighten load on makedepends
Diffstat (limited to 'testing/py-urlobject')
-rw-r--r--testing/py-urlobject/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/testing/py-urlobject/APKBUILD b/testing/py-urlobject/APKBUILD
index 589675bd95..552ae661ab 100644
--- a/testing/py-urlobject/APKBUILD
+++ b/testing/py-urlobject/APKBUILD
@@ -1,3 +1,4 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-urlobject
@@ -7,26 +8,23 @@ pkgrel=1
pkgdesc="A Python utility class for manipulating URLs"
url="https://github.com/dperezrada/html2data"
arch="noarch"
-license="Public-Domain"
-options="!check"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
+license="Unlicense"
+makedepends="py-setuptools py3-setuptools"
+checkdepends="py-nose py3-nose"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python2 setup.py build
python3 setup.py build
}
# Tests are not included at the moment
-#check() {
-# cd "$builddir"
-# nosetests -w test
-# nosetests-3.6 -w test
-#}
+check() {
+ PYTHONPATH="${PWD}/build/lib" nosetests-2.7 -w test
+ PYTHONPATH="${PWD}/build/lib" nosetests -w test
+}
package() {
mkdir -p "$pkgdir"