aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-wcwidth
diff options
context:
space:
mode:
authorThomas Boerger <thomas@webhippie.de>2016-07-06 10:00:46 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-07-06 18:37:10 +0200
commit10ec44768d6f3e63d9346e2de7a398286cbeaf9a (patch)
tree9f939f9359ee7b3ffaa9857be6b46f350a939844 /testing/py-wcwidth
parent2aaf1f4cde69bb1daf1ba2bc94b4cfa872c90172 (diff)
downloadaports-10ec44768d6f3e63d9346e2de7a398286cbeaf9a.tar.bz2
aports-10ec44768d6f3e63d9346e2de7a398286cbeaf9a.tar.xz
testing/py-wcwidth: new aport
https://pypi.python.org/pypi/wcwidth Measures number of Terminal column cells of wide-character codes
Diffstat (limited to 'testing/py-wcwidth')
-rw-r--r--testing/py-wcwidth/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-wcwidth/APKBUILD b/testing/py-wcwidth/APKBUILD
new file mode 100644
index 0000000000..96c9aad5fb
--- /dev/null
+++ b/testing/py-wcwidth/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py-wcwidth
+_pkgname=wcwidth
+pkgver=0.1.7
+pkgrel=0
+pkgdesc="Measures number of Terminal column cells of wide-character codes"
+url="https://pypi.python.org/pypi/wcwidth"
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b3b6a0a08f0c8a34d1de8cf44150a4ad py-wcwidth-0.1.7.tar.gz"
+sha256sums="3df37372226d6e63e1b1e1eda15c594bca98a22d33a23832a90998faa96bc65e py-wcwidth-0.1.7.tar.gz"
+sha512sums="5bc9625fbd10721a50a3ac7d7f91012cca8e4f83533f265cf56890498bc52a53b155c82e67d6bc5523a5593c8d7992a1dec2a0f590318170eddf987c56f9c368 py-wcwidth-0.1.7.tar.gz"