aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py2-typing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-22 02:25:17 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-22 02:26:37 +0100
commit3c3f2b98432734b33225e4a3f8299bfa9abdd25b (patch)
treea4a2566b897f4bc5d22145725e897f3c99853655 /testing/py2-typing
parent5243ff1e414ece3d4bb1f52c88c00c2089d6a4d9 (diff)
downloadaports-3c3f2b98432734b33225e4a3f8299bfa9abdd25b.tar.bz2
aports-3c3f2b98432734b33225e4a3f8299bfa9abdd25b.tar.xz
testing/py2-typing: new aport
https://pypi.python.org/pypi/typing/ Backport of stdlib's typing module from Python 3.5
Diffstat (limited to 'testing/py2-typing')
-rw-r--r--testing/py2-typing/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py2-typing/APKBUILD b/testing/py2-typing/APKBUILD
new file mode 100644
index 0000000000..5ed8001998
--- /dev/null
+++ b/testing/py2-typing/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py2-typing
+_pkgname=typing
+pkgver=3.5.2.2
+pkgrel=0
+pkgdesc="Backport of stdlib's typing module from Python 3.5"
+url="https://pypi.python.org/pypi/typing/"
+arch="noarch"
+license="PSF"
+depends="python2"
+makedepends="python2-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+md5sums="61ffbe736df9f419563dbfffa64ebb7d py2-typing-3.5.2.2.tar.gz"
+sha256sums="2bce34292653af712963c877f3085250a336738e64f99048d1b8509bebc4772f py2-typing-3.5.2.2.tar.gz"
+sha512sums="38d8899cf7ccfc86299ea59a234a80a7938ff9e78d84a9593befd163959ee90af3201dfd495e172904bc6423919b338bee470d166e9c41d9697662c27ed2fbc8 py2-typing-3.5.2.2.tar.gz"