aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-affine
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2019-12-14 22:06:25 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-15 16:22:19 +0100
commitbf35fb7e03e41a1bf944c34d76313f12b1056a1a (patch)
treed2fb2fb1d49e2ad9a31e01217ede8c2567254971 /testing/py3-affine
parent82a82bf59bafac377dfd41894a751de9de0d83fd (diff)
downloadaports-bf35fb7e03e41a1bf944c34d76313f12b1056a1a.tar.bz2
aports-bf35fb7e03e41a1bf944c34d76313f12b1056a1a.tar.xz
testing/py3-affine: new aport
Diffstat (limited to 'testing/py3-affine')
-rw-r--r--testing/py3-affine/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py3-affine/APKBUILD b/testing/py3-affine/APKBUILD
new file mode 100644
index 0000000000..5a0a772cd2
--- /dev/null
+++ b/testing/py3-affine/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
+# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
+_pkgname=affine
+pkgname=py3-$_pkgname
+pkgver=2.3.0
+pkgrel=0
+pkgdesc="Affine transformation matrices"
+url="https://pypi.org/project/affine/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ python3
+ "
+makedepends="
+ py3-setuptools
+ "
+checkdepends="
+ pytest
+ "
+source="
+ py3-affine-$pkgver.tar.gz::https://github.com/sgillies/affine/archive/$pkgver.tar.gz
+ "
+builddir="$srcdir/affine-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/*/tests
+}
+
+sha512sums="25e3671542a4bcb45c04a3e4a1c312f7e427091470b30b115dd8d0c7a1f3ac008e1b1f9222ca60b08b4717cab90fc224f2e70fc0184ca371ccf918f8c04a23ce py3-affine-2.3.0.tar.gz"