aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-allfiles
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-04-27 22:41:00 +0300
committerprspkt <prspkt@protonmail.com>2019-04-27 22:41:22 +0300
commit0de75608b99cef2f2189f4d0c878839e5f30c1cb (patch)
tree511762b87041344e9434c81348a2281e9f5e6881 /testing/py3-allfiles
parentcfd752d17d260d6ba27c739685ddf35811b6bb72 (diff)
downloadaports-0de75608b99cef2f2189f4d0c878839e5f30c1cb.tar.bz2
aports-0de75608b99cef2f2189f4d0c878839e5f30c1cb.tar.xz
testing/py3-allfiles: modernize
Diffstat (limited to 'testing/py3-allfiles')
-rw-r--r--testing/py3-allfiles/APKBUILD27
1 files changed, 6 insertions, 21 deletions
diff --git a/testing/py3-allfiles/APKBUILD b/testing/py3-allfiles/APKBUILD
index 590f9c3f45..1eb5404508 100644
--- a/testing/py3-allfiles/APKBUILD
+++ b/testing/py3-allfiles/APKBUILD
@@ -4,40 +4,25 @@ pkgname=py3-allfiles
_pkgname=allfiles
pkgver=1.0
pkgrel=0
-pkgdesc="A Python iterator for matching files in directory trees"
+pkgdesc="Iterator for matching files in directory trees"
url="https://pypi.python.org/pypi/allfiles"
arch="noarch"
license="MIT"
replaces="py-allfiles" # for backwards compatibility
provides="py-allfiles=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-depends_dev=""
makedepends="py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="d25991ebdc6277f60b90057c565f3b2d allfiles-1.0.zip"
-sha256sums="0265c4531e2606afea3f975d503bddc91618fdd55d9901430795576c5db14524 allfiles-1.0.zip"
sha512sums="698f1131950eba7cc12af727e2c27c5018c1d81ab1cca7f94f308061220003b5b412ef4720ba1bbebc50e7fee4f5549c43868d2cfe81e99df1f78e6bf7c38d0f allfiles-1.0.zip"