aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ansicolors
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-05 21:27:25 +0300
committerprspkt <prspkt@protonmail.com>2019-06-05 21:27:25 +0300
commit4fef553d7972466db913aba9905c7d61594b822f (patch)
tree9ab97d5445cfadcff1ac1cc44e2afe3f31065d40 /testing/py3-ansicolors
parent1d2d74fdad190bd5bca2a10b44f2ff71f28340a3 (diff)
downloadaports-4fef553d7972466db913aba9905c7d61594b822f.tar.bz2
aports-4fef553d7972466db913aba9905c7d61594b822f.tar.xz
testing/py3-ansicolors: modernize
Diffstat (limited to 'testing/py3-ansicolors')
-rw-r--r--testing/py3-ansicolors/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/testing/py3-ansicolors/APKBUILD b/testing/py3-ansicolors/APKBUILD
index 2913d52ad5..3b11533609 100644
--- a/testing/py3-ansicolors/APKBUILD
+++ b/testing/py3-ansicolors/APKBUILD
@@ -3,26 +3,24 @@
pkgname=py3-ansicolors
_pkgname=ansicolors
pkgver=1.1.8
-pkgrel=1
+pkgrel=2
pkgdesc="ANSI colors for Python"
url="https://github.com/jonathaneunice/colors"
arch="noarch"
license="ISC"
-provides="py-ansicolors" # for backwards compatibility
-replaces="py-ansicolors=$pkgver-r$pkgrel" # for backwards compatibility
+replaces="py-ansicolors" # for backwards compatibility
+provides="py-ansicolors=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip
fix-requires.patch"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}