aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-argcomplete
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 01:56:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 02:16:30 -0300
commitf57f3953e60bc69bde476f05882fb789047d367a (patch)
tree862cd12984ec2d1adc53a63d5b6d2365db1c5e6b /testing/py3-argcomplete
parentf7f276c94934ee3de7fbefc57efef5fc8454a24d (diff)
downloadaports-f57f3953e60bc69bde476f05882fb789047d367a.tar.bz2
aports-f57f3953e60bc69bde476f05882fb789047d367a.tar.xz
testing/py3-argcomplete: upgrade to 1.10.0
Diffstat (limited to 'testing/py3-argcomplete')
-rw-r--r--testing/py3-argcomplete/APKBUILD48
1 files changed, 17 insertions, 31 deletions
diff --git a/testing/py3-argcomplete/APKBUILD b/testing/py3-argcomplete/APKBUILD
index 40a173e3e2..0aaee698b6 100644
--- a/testing/py3-argcomplete/APKBUILD
+++ b/testing/py3-argcomplete/APKBUILD
@@ -1,47 +1,33 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer:
-pkgname=py-argcomplete
-_pkgname=${pkgname#py-}
-pkgver=1.9.4
-pkgrel=1
+pkgname=py3-argcomplete
+_pkgname=${pkgname#py3-}
+pkgver=1.10.0
+pkgrel=0
pkgdesc="Easy, extensible command line tab completion of arguments for your Python script"
+options="!check" # Tests are py2 dependent
url="https://github.com/kislyuk/argcomplete"
arch="noarch"
license="Apache-2.0"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://github.com/kislyuk/$_pkgname/archive/v$pkgver.tar.gz"
+makedepends="py3-setuptools"
+checkdepends="py3-coverage py3-flake8 py3-pexpect bash"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kislyuk/$_pkgname/archive/v$pkgver.tar.gz
+ "
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-argcomplete" # Backwards compatibility
+provides="py-argcomplete=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr \
- --root="$subpkgdir" --optimize=1
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
+check() {
+ python3 setup.py test
}
-_py3() {
- _py python3
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}
-sha512sums="2b0900b55136739f409c32172933af985f4cdde1c018a4687d02f0c5ecdaf36eb8f960270d16bbd157e79f76992c437ab42fd4c6aa9b6aeb3c7302935bf00970 py-argcomplete-1.9.4.tar.gz"
+sha512sums="bbed1666698eca49477bef768f416eb3fed9157d43d0ad19d221302a47625743395947377011536fb3d26a411a17b8b53807350ed616629c65e1e017967e9124 py3-argcomplete-1.10.0.tar.gz"