aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-argon2-cffi
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-07-26 09:19:59 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-26 19:04:31 -0300
commit33467425e16df98d223e4ccb2ebc9147762656b8 (patch)
tree82cccefce394908890aaaca64d49a786b669ccc7 /testing/py3-argon2-cffi
parentbe234fd2d2f8d6281a3f126a6551e867f2d43205 (diff)
downloadaports-33467425e16df98d223e4ccb2ebc9147762656b8.tar.bz2
aports-33467425e16df98d223e4ccb2ebc9147762656b8.tar.xz
testing/py3-argon2-cffi: new aport
Diffstat (limited to 'testing/py3-argon2-cffi')
-rw-r--r--testing/py3-argon2-cffi/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-argon2-cffi/APKBUILD b/testing/py3-argon2-cffi/APKBUILD
new file mode 100644
index 0000000000..6999ad3040
--- /dev/null
+++ b/testing/py3-argon2-cffi/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-argon2-cffi
+pkgver=19.1.0
+pkgrel=0
+pkgdesc="The secure Argon2 password hashing algorithm"
+url="The secure Argon2 password hashing algorithm"
+arch="all"
+license="MIT"
+depends="python3"
+makedepends="argon2-dev python3-dev py3-setuptools libffi-dev"
+checkdepends="py3-pytest py3-hypothesis"
+source="https://pypi.io/packages/source/a/argon2_cffi/argon2_cffi-$pkgver.tar.gz"
+builddir="$srcdir/argon2_cffi-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9bc10f0dfbb199e0ae0c9bd6a7c9183a5b0b108966d89bacf8ee744a926d400bccc14869b889a2482be4a5c48bd7ed0464cf316ecad74b758a5493beed7d466c argon2_cffi-19.1.0.tar.gz"