aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-arrow
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-06 01:00:46 +0300
committerprspkt <prspkt@protonmail.com>2019-06-06 01:00:46 +0300
commit3c5323ab200e64d553e4007d701b60ffe65f30f9 (patch)
tree71644f4f9f5d1dfa322204dfba691da7858e2498 /testing/py3-arrow
parent2d854270334fd2c17e7231a7e48e0cb558faca25 (diff)
downloadaports-3c5323ab200e64d553e4007d701b60ffe65f30f9.tar.bz2
aports-3c5323ab200e64d553e4007d701b60ffe65f30f9.tar.xz
testing/py-arrow: drop python2
Diffstat (limited to 'testing/py3-arrow')
-rw-r--r--testing/py3-arrow/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-arrow/APKBUILD b/testing/py3-arrow/APKBUILD
new file mode 100644
index 0000000000..bd07ab861e
--- /dev/null
+++ b/testing/py3-arrow/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-arrow
+_pkgname=arrow
+pkgver=0.10.0
+pkgrel=3
+pkgdesc="Python3 library to create and manipulate dates, times, and timestamps"
+url="https://arrow.readthedocs.io/"
+arch="noarch"
+license="Apache-2.0"
+depends="py3-dateutil"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-arrow" # for backwards compatibility
+provides="py-arrow=$pkgname-$pkgver" # for backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a2baa23f1424b21506f3b664f0ef02d09f91b9cfaf6e0badfa544f42c750ed51136ae0e8910ac24207c0265a1b233f10a6f3cbafee3124b5f5c4fd965cfd01c0 arrow-0.10.0.tar.gz"