aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-audioread
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-24 21:10:08 +0300
committerprspkt <prspkt@protonmail.com>2019-06-24 21:28:20 +0300
commit8cbc0e3d66e6c11e45fa137b3582e63b2e816b73 (patch)
tree3969129a7c4959cd82c0f12b7a310294944e3cc9 /testing/py3-audioread
parenta1cf4add5e268835abda0adda8ff94569020df0c (diff)
downloadaports-8cbc0e3d66e6c11e45fa137b3582e63b2e816b73.tar.bz2
aports-8cbc0e3d66e6c11e45fa137b3582e63b2e816b73.tar.xz
testing/py3-audioread: modernize
Diffstat (limited to 'testing/py3-audioread')
-rw-r--r--testing/py3-audioread/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/testing/py3-audioread/APKBUILD b/testing/py3-audioread/APKBUILD
index f281d13930..0fa79aa6e9 100644
--- a/testing/py3-audioread/APKBUILD
+++ b/testing/py3-audioread/APKBUILD
@@ -4,27 +4,24 @@ pkgname=py3-audioread
_pkgname=audioread
pkgver=2.1.5
pkgrel=2
-pkgdesc="Cross-library audio decoding for Python"
+pkgdesc="Multi-library, cross-platform audio decoding"
url="https://github.com/sampsyo/audioread"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
options="!check" # upstream provides no testsuite
-source="https://files.pythonhosted.org/packages/source/a/audioread/audioread-$pkgver.tar.gz"
-
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-audioread" # Backwards compatibility
provides="py-audioread=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}