aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-axolotl/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 20:14:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-21 01:16:16 -0300
commit552ac972efa1e4d2a37ca3bf89b134c89275aa4a (patch)
treec0bf5e66708542098d2bedfa47926c7f8f27ced7 /testing/py3-axolotl/APKBUILD
parent3a19935f6a843fa5f0403018f88ecb0e4410d56e (diff)
downloadaports-552ac972efa1e4d2a37ca3bf89b134c89275aa4a.tar.bz2
aports-552ac972efa1e4d2a37ca3bf89b134c89275aa4a.tar.xz
testing/py3-axolotl: switch to py3
Diffstat (limited to 'testing/py3-axolotl/APKBUILD')
-rw-r--r--testing/py3-axolotl/APKBUILD44
1 files changed, 11 insertions, 33 deletions
diff --git a/testing/py3-axolotl/APKBUILD b/testing/py3-axolotl/APKBUILD
index b0850dfb38..8eee3123ba 100644
--- a/testing/py3-axolotl/APKBUILD
+++ b/testing/py3-axolotl/APKBUILD
@@ -1,53 +1,31 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-pkgname=py-axolotl
-_pkgname="python-${pkgname#py-}"
+pkgname=py3-axolotl
+_pkgname="python-${pkgname#py3-}"
pkgver=0.1.42
-pkgrel=1
+pkgrel=2
pkgdesc="Python port of libsignal-protocol-java"
url="https://github.com/tgalal/python-axolotl"
arch="noarch"
license="GPL-3.0-only"
-depends="py-crypto py-protobuf py-axolotl-curve25519"
-makedepends="py-setuptools python2-dev python3-dev openssl-dev"
-checkdepends="py-cryptography py-cparser"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-cryptography py3-protobuf py3-axolotl-curve25519"
+makedepends="py3-setuptools"
+checkdepends="py3-cparser"
source="$pkgname-$pkgver.tar.gz::https://github.com/tgalal/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-axolotl" # Backwards compatibility
+provides="py-axolotl=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="db9e1cfab87d690619a672b1782942a18b12b17af555959c17bcc3e2581e9c689c57becc0ea884a1129df9dace17684ba03de38b81f8c8c65cab27962ebdb6c5 py-axolotl-0.1.42.tar.gz"
+sha512sums="db9e1cfab87d690619a672b1782942a18b12b17af555959c17bcc3e2581e9c689c57becc0ea884a1129df9dace17684ba03de38b81f8c8c65cab27962ebdb6c5 py3-axolotl-0.1.42.tar.gz"