aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bandwidth-sdk
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-23 16:02:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-23 16:18:58 -0300
commit116d0a2727d1e82c0ad615e745648496b5b6b8fe (patch)
tree5d0ec70198909d29025e458cf0c402e1ef76e8a1 /testing/py3-bandwidth-sdk
parente65b518f1be7d3b1555525028341223cacf0c9be (diff)
downloadaports-116d0a2727d1e82c0ad615e745648496b5b6b8fe.tar.bz2
aports-116d0a2727d1e82c0ad615e745648496b5b6b8fe.tar.xz
testing/py3-bandwidth-sdk: rename from py-bandwidth-sdk
Diffstat (limited to 'testing/py3-bandwidth-sdk')
-rw-r--r--testing/py3-bandwidth-sdk/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py3-bandwidth-sdk/APKBUILD b/testing/py3-bandwidth-sdk/APKBUILD
new file mode 100644
index 0000000000..1db7fb5e02
--- /dev/null
+++ b/testing/py3-bandwidth-sdk/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer:
+pkgname=py-bandwidth-sdk
+pkgver=1.10
+pkgrel=2
+pkgdesc="python helpers for using bandwidth.com API"
+url="https://pypi.python.org/pypi/bandwidth-sdk/"
+arch="noarch"
+license="BSD"
+depends="py-requests py-dateutil"
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-bandwidth-sdk:py2 py3-bandwidth-sdk:py3"
+source="bandwidth-sdk-$pkgver.tar.gz::https://github.com/Bandwidth/python-bandwidth/archive/$pkgver.tar.gz"
+builddir="$srcdir/python-bandwidth-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="f8350172af1614e924f264469f5dd246381efb3eae7a8d16f6fc3d4cf2526c74f4dd78f8e16379a898f6ddd2483d68bc170250a07ec1adadce8b50939b56b504 bandwidth-sdk-1.10.tar.gz"