aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-billiard
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 02:06:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 03:26:13 -0300
commit3ef2764898917a4efbb5e8fa63a6a66767a7187e (patch)
tree18dde6f299d26f58b373e817bd7b61c8f1522d70 /testing/py3-billiard
parentaacb5e1c8866881f54ce75765a238976d76699bb (diff)
downloadaports-3ef2764898917a4efbb5e8fa63a6a66767a7187e.tar.bz2
aports-3ef2764898917a4efbb5e8fa63a6a66767a7187e.tar.xz
testing/py3-billiard: upgrade to 3.6.1.0
Diffstat (limited to 'testing/py3-billiard')
-rw-r--r--testing/py3-billiard/APKBUILD45
1 files changed, 15 insertions, 30 deletions
diff --git a/testing/py3-billiard/APKBUILD b/testing/py3-billiard/APKBUILD
index dfc5f90072..871639475a 100644
--- a/testing/py3-billiard/APKBUILD
+++ b/testing/py3-billiard/APKBUILD
@@ -1,44 +1,29 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=py-billiard
-pkgver=3.6.0.0
-pkgrel=1
+pkgname=py3-billiard
+pkgver=3.6.1.0
+pkgrel=0
pkgdesc="a message queue abstraction layer"
url="https://pypi.python.org/pypi/billiard/"
-arch="all"
-license="BSD"
-makedepends="python2-dev python3-dev py2-setuptools py3-setuptools"
-subpackages="py2-billiard:py2 py3-billiard:py3"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="py3-setuptools"
+checkdepends="py3-psutil py3-pytest py3-nose py3-case"
source="https://files.pythonhosted.org/packages/source/b/billiard/billiard-$pkgver.tar.gz"
builddir="$srcdir/billiard-$pkgver"
+replaces="py-billiard" # Backwards compatibility
+provides="py-billiard=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$_builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ${python#python}"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-py2() {
- cd "$builddir"
- _py python2
+check() {
+ python3 setup.py test
}
-py3() {
- cd "$builddir"
- _py python3
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0a71de026d2a781b83fe2c549ecbfe9b6fbd574d8067fc46ba7eca6b76633a123620853d22696df3563d050043cfe75b14b4b69bf5217e0af964aaa0bcbe08ff billiard-3.6.0.0.tar.gz"
+sha512sums="d0250d30bc22340ef0931df6c909c6353fcda486d0a9100c3ec922ce8284bb0b359faba2d696ddc3ddb8eb4dc7d8e07fe7e2f2cf3244b67a5ed90ebad8c5f68b billiard-3.6.1.0.tar.gz"