aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-billiard
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 02:02:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 03:26:12 -0300
commitaacb5e1c8866881f54ce75765a238976d76699bb (patch)
tree11b2980a414053d7a94207d3f8632e1b07a3bb3a /testing/py3-billiard
parent557456a99ccf2c03c085b1b2f369a67063c132bc (diff)
downloadaports-aacb5e1c8866881f54ce75765a238976d76699bb.tar.bz2
aports-aacb5e1c8866881f54ce75765a238976d76699bb.tar.xz
testing/py3-billiard: rename from py-billiard
Diffstat (limited to 'testing/py3-billiard')
-rw-r--r--testing/py3-billiard/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/py3-billiard/APKBUILD b/testing/py3-billiard/APKBUILD
new file mode 100644
index 0000000000..dfc5f90072
--- /dev/null
+++ b/testing/py3-billiard/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py-billiard
+pkgver=3.6.0.0
+pkgrel=1
+pkgdesc="a message queue abstraction layer"
+url="https://pypi.python.org/pypi/billiard/"
+arch="all"
+license="BSD"
+makedepends="python2-dev python3-dev py2-setuptools py3-setuptools"
+subpackages="py2-billiard:py2 py3-billiard:py3"
+source="https://files.pythonhosted.org/packages/source/b/billiard/billiard-$pkgver.tar.gz"
+builddir="$srcdir/billiard-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="0a71de026d2a781b83fe2c549ecbfe9b6fbd574d8067fc46ba7eca6b76633a123620853d22696df3563d050043cfe75b14b4b69bf5217e0af964aaa0bcbe08ff billiard-3.6.0.0.tar.gz"