aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-blessings/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-20 01:48:57 +0300
committerprspkt <prspkt@protonmail.com>2019-06-20 01:51:20 +0300
commit8010b2d1aed2910a5ad1ef73b0761453f343c67d (patch)
tree3a937a91eead961555937ed4c25285402d98e1bc /testing/py3-blessings/APKBUILD
parentc885a7a604757405692f466476d6173bfdb3fda6 (diff)
downloadaports-8010b2d1aed2910a5ad1ef73b0761453f343c67d.tar.bz2
aports-8010b2d1aed2910a5ad1ef73b0761453f343c67d.tar.xz
testing/py3-blessings: disable test suite
* Tests expect a real terminal in order to perform color manipulations.
Diffstat (limited to 'testing/py3-blessings/APKBUILD')
-rw-r--r--testing/py3-blessings/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/testing/py3-blessings/APKBUILD b/testing/py3-blessings/APKBUILD
index a72509d948..42d9f4f777 100644
--- a/testing/py3-blessings/APKBUILD
+++ b/testing/py3-blessings/APKBUILD
@@ -3,14 +3,14 @@
pkgname=py3-blessings
_pkgname=blessings
pkgver=1.7
-pkgrel=3
+pkgrel=4
pkgdesc="Python library for terminal coloring, styling and positioning"
url="https://github.com/erikrose/blessings"
arch="noarch"
license="MIT"
depends="py3-six"
makedepends="py3-setuptools"
-checkdepends="py3-nose"
+options="!check" # tests require a real terminal
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -18,10 +18,6 @@ build() {
python3 setup.py build
}
-check() {
- nosetests build/lib
-}
-
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}