aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-blessings/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-20 00:31:38 +0300
committerprspkt <prspkt@protonmail.com>2019-06-20 01:02:40 +0300
commit8b203561f3c62d6f269b8febde0205522c47a35d (patch)
tree17b743b169b935064a6868a37dd1b2e62ab85af7 /testing/py3-blessings/APKBUILD
parentcef7ce2f8e12c551b8d04a245fd5746c5e37739b (diff)
downloadaports-8b203561f3c62d6f269b8febde0205522c47a35d.tar.bz2
aports-8b203561f3c62d6f269b8febde0205522c47a35d.tar.xz
testing/py-blessings: drop python2
Diffstat (limited to 'testing/py3-blessings/APKBUILD')
-rw-r--r--testing/py3-blessings/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-blessings/APKBUILD b/testing/py3-blessings/APKBUILD
new file mode 100644
index 0000000000..199e986918
--- /dev/null
+++ b/testing/py3-blessings/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-blessings
+_pkgname=blessings
+pkgver=1.7
+pkgrel=2
+pkgdesc="Wrapper around terminal coloring, styling and positioning"
+url="https://github.com/erikrose/blessings"
+arch="noarch"
+license="MIT"
+depends="py3-six"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="66a8e7af6a8807c8be68f4d71db25ca6c26f46ddfa9a7e4792a2f73033df81d8392633ff75e6fa131039d9136030844ed93b11316b9f7e2e6ea77675f2f3e528 blessings-1.7.tar.gz"