aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-blessings
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-20 00:43:36 +0300
committerprspkt <prspkt@protonmail.com>2019-06-20 01:02:41 +0300
commit2a09c46255821fe98296865629a490377bca88f0 (patch)
tree49e2478df20c05abf656b496432c9b0c0b5e886c /testing/py3-blessings
parent8b203561f3c62d6f269b8febde0205522c47a35d (diff)
downloadaports-2a09c46255821fe98296865629a490377bca88f0.tar.bz2
aports-2a09c46255821fe98296865629a490377bca88f0.tar.xz
testing/py3-blessings: modernize
* Add checkdepends and run test suite.
Diffstat (limited to 'testing/py3-blessings')
-rw-r--r--testing/py3-blessings/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/testing/py3-blessings/APKBUILD b/testing/py3-blessings/APKBUILD
index 199e986918..4508098357 100644
--- a/testing/py3-blessings/APKBUILD
+++ b/testing/py3-blessings/APKBUILD
@@ -4,23 +4,25 @@ pkgname=py3-blessings
_pkgname=blessings
pkgver=1.7
pkgrel=2
-pkgdesc="Wrapper around terminal coloring, styling and positioning"
+pkgdesc="Python library for terminal coloring, styling and positioning"
url="https://github.com/erikrose/blessings"
arch="noarch"
license="MIT"
depends="py3-six"
makedepends="py3-setuptools"
+checkdepends="py3-nose"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ nosetests build/lib
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}