aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-api
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-30 17:34:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 08:19:30 -0300
commit0d9ac154c4bd382f1abb29d4af5e4d1b03066180 (patch)
treeb8dc05c531f70e69f7c021d95ef2ca9f27ca7593 /testing/py3-bottle-api
parent33c540ab33d7054e2a0944498609a99428cb875c (diff)
downloadaports-0d9ac154c4bd382f1abb29d4af5e4d1b03066180.tar.bz2
aports-0d9ac154c4bd382f1abb29d4af5e4d1b03066180.tar.xz
testing/py3-bottle-api: rename from py-bottle-api
Diffstat (limited to 'testing/py3-bottle-api')
-rw-r--r--testing/py3-bottle-api/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-bottle-api/APKBUILD b/testing/py3-bottle-api/APKBUILD
new file mode 100644
index 0000000000..df9419febb
--- /dev/null
+++ b/testing/py3-bottle-api/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-api
+_pkgname=bottle-api
+pkgver=0.0.2
+pkgrel=0
+pkgdesc="Bottle JSON Web API"
+url="https://github.com/tomotaka/bottle-api"
+arch="noarch"
+license="MIT"
+depends="python2 py-bottle"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6b064de05dd43c0d2373ea1c4e1355f4 bottle-api-0.0.2.tar.gz"
+sha256sums="1e8c5a6921d639b376ade65d5d60a173353f8587f5e38a6653b951a413caedf8 bottle-api-0.0.2.tar.gz"
+sha512sums="d66e33fb5b721bfab7c968b394b17d3953ff0290b3db384002675ab116a7051c7fb6ee5d35285bf2adc224fe22d80668c6339e689458e073bbbecb393384582e bottle-api-0.0.2.tar.gz"