aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-hotqueue
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:05:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:08:01 -0300
commit6fbf8049d55b0a3b2cc3080cf6462f893d62cce0 (patch)
tree541513f61a8f83ef553a5a8a240364a17c5e78fe /testing/py3-bottle-hotqueue
parent8da8bfaa3145562a0662a5ca3acce6c2fe9c589a (diff)
downloadaports-6fbf8049d55b0a3b2cc3080cf6462f893d62cce0.tar.bz2
aports-6fbf8049d55b0a3b2cc3080cf6462f893d62cce0.tar.xz
testing/py3-bottle-hotqueue: drop py2
Diffstat (limited to 'testing/py3-bottle-hotqueue')
-rw-r--r--testing/py3-bottle-hotqueue/APKBUILD35
1 files changed, 8 insertions, 27 deletions
diff --git a/testing/py3-bottle-hotqueue/APKBUILD b/testing/py3-bottle-hotqueue/APKBUILD
index 9492b54684..9c738124ba 100644
--- a/testing/py3-bottle-hotqueue/APKBUILD
+++ b/testing/py3-bottle-hotqueue/APKBUILD
@@ -1,47 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-bottle-hotqueue
+pkgname=py3-bottle-hotqueue
_pkgname=bottle-hotqueue
pkgver=0.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="Bottle HotQueue plugin"
+options="!check" # No testsuite
url="https://github.com/waawal/bottle_hotqueue"
arch="noarch !armv7"
license="MIT"
-depends="py-bottle py-hotqueue"
-makedepends="py-setuptools py3-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-bottle py3-hotqueue"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-bottle-hotqueue" # Backwards compatibility
+provides="py-bottle-hotqueue=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
package() {
- python2 setup.py install --prefix=/usr --root="$pkgdir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
sha512sums="0ee8a1254d3997b7066443100a27de5ca22b31f4c24bd2bc92bb41fa296516a9096d170e1d48b30dea192fe424b3d9b487b851c6a4c272c0c4a55681a1afc2dc bottle-hotqueue-0.2.5.tar.gz"