aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-redis
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:14:39 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:18:57 -0300
commitb905b2d68dcf2cb70328e0a5780b905a8ea66d2d (patch)
treefe165b9181fd93ec6cab786e294354d2eb00c9eb /testing/py3-bottle-redis
parent84813fdf64762b197c9391c4ab6a2a002964980f (diff)
downloadaports-b905b2d68dcf2cb70328e0a5780b905a8ea66d2d.tar.bz2
aports-b905b2d68dcf2cb70328e0a5780b905a8ea66d2d.tar.xz
testing/py3-bottle-redis: drop py2
Diffstat (limited to 'testing/py3-bottle-redis')
-rw-r--r--testing/py3-bottle-redis/APKBUILD33
1 files changed, 10 insertions, 23 deletions
diff --git a/testing/py3-bottle-redis/APKBUILD b/testing/py3-bottle-redis/APKBUILD
index 506b25e07c..221b920e0f 100644
--- a/testing/py3-bottle-redis/APKBUILD
+++ b/testing/py3-bottle-redis/APKBUILD
@@ -1,41 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-bottle-redis
+pkgname=py3-bottle-redis
_pkgname=bottle-redis
pkgver=0.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Bottle redis plugin"
+options="!check" # No testsuite
url="https://github.com/bottlepy/bottle-redis"
arch="noarch"
license="MIT"
-depends="python2 py-bottle py-redis"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="python3 py3-bottle py3-redis"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-bottle-redis" # Backwards compatibility
+provides="py-bottle-redis=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="884fadac271f10fba90c2886e4682f4b bottle-redis-0.2.1.tar.gz"
-sha256sums="656fc3d42cec1e935d7aa40b314e714b9bfec1fa9044b0f1731bc8fcb6bb16f9 bottle-redis-0.2.1.tar.gz"
sha512sums="2db020bb786113e32d7f9dcf6fceb80426f7bd154eb3e5403372c7ebb82c55a8df0aad7a5fca6e47b1329eee1c14d1bfb833734951597083717da742a6461b91 bottle-redis-0.2.1.tar.gz"