aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-request
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:12:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:17:33 -0300
commit3ac0f249a1d80caeb147fbd93199f9fb44985331 (patch)
tree4d644d6eaaf2fa49bbb5c66ff252aff1e573dd49 /testing/py3-bottle-request
parentfb5ee31f62ded1875ca1c059df2ec2f8f35574ec (diff)
downloadaports-3ac0f249a1d80caeb147fbd93199f9fb44985331.tar.bz2
aports-3ac0f249a1d80caeb147fbd93199f9fb44985331.tar.xz
testing/py3-bottle-request: drop py2
Diffstat (limited to 'testing/py3-bottle-request')
-rw-r--r--testing/py3-bottle-request/APKBUILD33
1 files changed, 10 insertions, 23 deletions
diff --git a/testing/py3-bottle-request/APKBUILD b/testing/py3-bottle-request/APKBUILD
index 778fd4ced7..bfcf6d353e 100644
--- a/testing/py3-bottle-request/APKBUILD
+++ b/testing/py3-bottle-request/APKBUILD
@@ -1,41 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-bottle-request
+pkgname=py3-bottle-request
_pkgname=bottle-request
pkgver=0.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Bottle 'stateless' request object plugin"
+options="!check" # No testsuite
url="http://github.com/turtlebender/bottle-request/"
arch="noarch"
license="MIT"
-depends="python2 py-bottle"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="python3 py3-bottle"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-bottle-request" # Backwards compatibility
+provides="py-bottle-request=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="4da8d6bfebf4a9a80b70948cbd234dc7 bottle-request-0.2.0.tar.gz"
-sha256sums="e41f764dd7ea94eb4a65d492e354eac0500123d15c2a80bc6582ea8a793bf84f bottle-request-0.2.0.tar.gz"
sha512sums="bd12268d703996e200dea5817f939ecf80e572e97d3686bcaf988ec048cda4e3b950122588b91ce78a06712a321e155e2e365bc75bbd2a720228a65441a67e21 bottle-request-0.2.0.tar.gz"