aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-rest
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-30 17:41:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 08:00:19 -0300
commitc4dac8639064ffcea8e74bf8f800de0ed69cd67a (patch)
tree4fac85ad6d95fde3db065ff59c3160bc0664e358 /testing/py3-bottle-rest
parent1dc0800c38f2a56e477cfb041ee237cb6ae73697 (diff)
downloadaports-c4dac8639064ffcea8e74bf8f800de0ed69cd67a.tar.bz2
aports-c4dac8639064ffcea8e74bf8f800de0ed69cd67a.tar.xz
testing/py3-bottle-rest: rename from py-bottle-rest
Diffstat (limited to 'testing/py3-bottle-rest')
-rw-r--r--testing/py3-bottle-rest/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-bottle-rest/APKBUILD b/testing/py3-bottle-rest/APKBUILD
new file mode 100644
index 0000000000..90b231dfaf
--- /dev/null
+++ b/testing/py3-bottle-rest/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-rest
+_pkgname=bottle-rest
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="A decorator for REST in Bottle"
+url="https://pypi.python.org/pypi/bottle-rest/"
+arch="noarch"
+license="MIT"
+depends="python2 py-bottle"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c69d0a1e21919718d6bce371311cb36a bottle-rest-0.4.0.tar.gz"
+sha256sums="ec50a134efc64b1ae330a6f024633756f2f866cbc265152d645104897060d423 bottle-rest-0.4.0.tar.gz"
+sha512sums="3a11d84ea3426ed3aff3036bef00b0277c90495659f8faba7fd2b08e853d2557f6726325df565d3181a8fb27314ccaf52336a540f860435f0acbd513727902b2 bottle-rest-0.4.0.tar.gz"