aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-session
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-30 17:45:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 08:00:20 -0300
commit7ce291d70af610c404c734111569a6e1660fe39c (patch)
tree4d0b16fd929d12a65ef3ed8a36109d55627ef28d /testing/py3-bottle-session
parenteb76395264980ab6c2fa807ecc6d08fa1b811b97 (diff)
downloadaports-7ce291d70af610c404c734111569a6e1660fe39c.tar.bz2
aports-7ce291d70af610c404c734111569a6e1660fe39c.tar.xz
testing/py3-bottle-session: rename from py-bottle-session
Diffstat (limited to 'testing/py3-bottle-session')
-rw-r--r--testing/py3-bottle-session/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-bottle-session/APKBUILD b/testing/py3-bottle-session/APKBUILD
new file mode 100644
index 0000000000..a8b96ea8e5
--- /dev/null
+++ b/testing/py3-bottle-session/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-session
+_pkgname=bottle-session
+pkgver=0.4
+pkgrel=0
+pkgdesc="Bottle session plugin"
+url="https://bitbucket.org/devries/bottle-session"
+arch="noarch"
+license="Artistic"
+depends="python2 py-bottle py-redis"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="21e876d4c0573f94cda51b68de512560 bottle-session-0.4.tar.gz"
+sha256sums="c62fb9348e3cdc3251ece83a0373c159859d435032afa68aa39fefd8f7ba89e1 bottle-session-0.4.tar.gz"
+sha512sums="1f052c1fbca1dc3ab0bb1352ef9c83a1cfcf4131d356543ce73226408335edc31780e4e486fdeb0bf1c0a2bf649efaa64267d42af0aa2ddb454ac2b01a48f53e bottle-session-0.4.tar.gz"