aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-sqlalchemy
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-30 18:15:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 08:00:24 -0300
commit1a35e57a9a417f9cbf090f9ed6a569d2aea76b79 (patch)
tree728f59b62396fe5e7c9cdbdbe19bd005507a3549 /testing/py3-bottle-sqlalchemy
parent390e263ac88fc446ad218acefa360a9873bf8264 (diff)
downloadaports-1a35e57a9a417f9cbf090f9ed6a569d2aea76b79.tar.bz2
aports-1a35e57a9a417f9cbf090f9ed6a569d2aea76b79.tar.xz
testing/py3-bottle-sqlalchemy: rename from py-bottle-sqlalchemy
Diffstat (limited to 'testing/py3-bottle-sqlalchemy')
-rw-r--r--testing/py3-bottle-sqlalchemy/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-bottle-sqlalchemy/APKBUILD b/testing/py3-bottle-sqlalchemy/APKBUILD
new file mode 100644
index 0000000000..34dbbf41f7
--- /dev/null
+++ b/testing/py3-bottle-sqlalchemy/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-sqlalchemy
+_pkgname=bottle-sqlalchemy
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="Bottle SQLAlchemy integration plugin"
+url="http://www.github.com/iurisilvio/bottle-sqlalchemy"
+arch="noarch"
+license="MIT"
+depends="python2 py-bottle py-sqlalchemy"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="22b16941cf5e9067aa65c2d981ceb935 bottle-sqlalchemy-0.4.2.tar.gz"
+sha256sums="db2a6e1a7c080d4f45227719436e39619adb1a252c2a7f0e67fd2f4cb4c53bda bottle-sqlalchemy-0.4.2.tar.gz"
+sha512sums="646e4d61693db30d4dae598febc22d80e87471468215d7b0e8a7cf20aa6b7ea980120c6e2a1d234e32908f7221efe451bb64dc28656b2ff5d4af7e0ac7fba56f bottle-sqlalchemy-0.4.2.tar.gz"