aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-werkzeug
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:10:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:10:50 -0300
commit492b7daa172b5fa3bf9f6e3afb4a5125cd2041d3 (patch)
tree5b337b2bdf17ebeb4ea482164b284faaa9113534 /testing/py3-bottle-werkzeug
parent78269710984c787058db4fc73a06c11d84961355 (diff)
downloadaports-492b7daa172b5fa3bf9f6e3afb4a5125cd2041d3.tar.bz2
aports-492b7daa172b5fa3bf9f6e3afb4a5125cd2041d3.tar.xz
testing/py3-bottle-werkzeug: drop py2
Diffstat (limited to 'testing/py3-bottle-werkzeug')
-rw-r--r--testing/py3-bottle-werkzeug/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/testing/py3-bottle-werkzeug/APKBUILD b/testing/py3-bottle-werkzeug/APKBUILD
index 0b0056a37c..5623e9ff6d 100644
--- a/testing/py3-bottle-werkzeug/APKBUILD
+++ b/testing/py3-bottle-werkzeug/APKBUILD
@@ -1,29 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-bottle-werkzeug
+pkgname=py3-bottle-werkzeug
_pkgname=bottle-werkzeug
pkgver=0.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Bottle werkzeug plugin"
url="https://pypi.python.org/pypi/bottle-werkzeug"
arch="noarch"
license="MIT"
-depends="python2 py-bottle py-werkzeug"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
+depends="python3 py3-bottle py3-werkzeug"
+makedepends="py3-setuptools"
options="!check"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-bottle-werkzeug" # Backwards compatibility
+provides="py-bottle-werkzeug=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="13fce3be73caa42c8cbdf437799c1fdb32a6e1ea513055ce9cd53788cea318a6d990b0975b39bcbad3b6fb2994d17d29651603687f59604e81508e61b3b0319a bottle-werkzeug-0.1.1.tar.gz"