aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-werkzeug
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:09:56 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:09:56 -0300
commit78269710984c787058db4fc73a06c11d84961355 (patch)
tree0850c80417a5fcaba86c7a9c08496059808dbb1a /testing/py3-bottle-werkzeug
parent6fbf8049d55b0a3b2cc3080cf6462f893d62cce0 (diff)
downloadaports-78269710984c787058db4fc73a06c11d84961355.tar.bz2
aports-78269710984c787058db4fc73a06c11d84961355.tar.xz
testing/py3-bottle-werkzeug: rename from py-bottle-werkzeug
Diffstat (limited to 'testing/py3-bottle-werkzeug')
-rw-r--r--testing/py3-bottle-werkzeug/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-bottle-werkzeug/APKBUILD b/testing/py3-bottle-werkzeug/APKBUILD
new file mode 100644
index 0000000000..0b0056a37c
--- /dev/null
+++ b/testing/py3-bottle-werkzeug/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-werkzeug
+_pkgname=bottle-werkzeug
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="Bottle werkzeug plugin"
+url="https://pypi.python.org/pypi/bottle-werkzeug"
+arch="noarch"
+license="MIT"
+depends="python2 py-bottle py-werkzeug"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+options="!check"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="13fce3be73caa42c8cbdf437799c1fdb32a6e1ea513055ce9cd53788cea318a6d990b0975b39bcbad3b6fb2994d17d29651603687f59604e81508e61b3b0319a bottle-werkzeug-0.1.1.tar.gz"