aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-businesstime
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-30 14:40:05 +0200
committerprspkt <prspkt@protonmail.com>2019-03-30 14:42:29 +0200
commit9ed094fdce22bff0710e5aa88e2ba555cebffb32 (patch)
tree1c6a1010bfea6f8ddfec7d8d3326beabb1b425a3 /testing/py3-businesstime
parent19157f3ccac125b527a14da2e3e9761ef770156a (diff)
downloadaports-9ed094fdce22bff0710e5aa88e2ba555cebffb32.tar.bz2
aports-9ed094fdce22bff0710e5aa88e2ba555cebffb32.tar.xz
testing/py3-businesstime: clarify license, modernize
Diffstat (limited to 'testing/py3-businesstime')
-rw-r--r--testing/py3-businesstime/APKBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/testing/py3-businesstime/APKBUILD b/testing/py3-businesstime/APKBUILD
index 4830253fc6..a4e924132a 100644
--- a/testing/py3-businesstime/APKBUILD
+++ b/testing/py3-businesstime/APKBUILD
@@ -4,40 +4,25 @@ pkgname=py3-businesstime
_pkgname=businesstime
pkgver=0.1.4
pkgrel=0
-pkgdesc="A Python utility for calculating business time between two datetimes"
+pkgdesc="Python utility for calculating business time between two datetimes"
url="https://github.com/seatgeek/businesstime"
arch="noarch"
-license="BSD"
+license="BSD-2-Clause"
provides="py-businesstime" # for backwards compatibility
replaces="py-businesstime=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-depends_dev=""
makedepends="python3-dev py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="6bba38b1f60d4a4d6c49ef9a0ef6a3ec businesstime-0.1.4.tar.gz"
-sha256sums="65514b0833c1234f82f7386956fe1b558fa70bdc5c05605dbdb740695d99c2a6 businesstime-0.1.4.tar.gz"
sha512sums="7ef7b6053855708c8aac48a8f6af34f55e2a389a6a7b954c3c6e2f542ced5ef22c73392c483b2fe8de387c0c8b57eea6edb0ce714ba66755b10d5ea3eb1add34 businesstime-0.1.4.tar.gz"