aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-case
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 02:47:24 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 03:03:15 -0300
commitdcd36cc9face2c807e539432cd74a1080dc98af9 (patch)
treeffeb1b827beef81b91aee81cec67ac74228691cc /testing/py3-case
parent50cc98143f9aec516d1ab782b60d2563038489ea (diff)
downloadaports-dcd36cc9face2c807e539432cd74a1080dc98af9.tar.bz2
aports-dcd36cc9face2c807e539432cd74a1080dc98af9.tar.xz
testing/py3-case: rename from py-case
Diffstat (limited to 'testing/py3-case')
-rw-r--r--testing/py3-case/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/testing/py3-case/APKBUILD b/testing/py3-case/APKBUILD
new file mode 100644
index 0000000000..13dbf88818
--- /dev/null
+++ b/testing/py3-case/APKBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py-case
+_pyname=case
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Python unittest utilities"
+url="https://github.com/celery/case/"
+arch="noarch"
+license="BSD"
+makedepends="python2-dev python3-dev py2-setuptools py3-setuptools"
+checkdepends="
+ py2-coverage py3-coverage py2-mock py3-mock py2-nose py3-nose py2-unittest2
+"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ cp -r "$builddir" "$builddir"-py2
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+ cd "$builddir"-py2
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+ cd "$builddir"-py2
+ python2 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ cd "$builddir"-py2
+ _py python2
+}
+
+_py3() {
+ cd "$builddir"
+ _py python3
+}
+
+_py() {
+ _python="$1"
+ pkgdesc="$pkgdesc (for $_python)"
+ depends="$depends $_python"
+ install_if="$pkgname=$pkgver-r$pkgrel $_python"
+ $_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="0ae03ab175903bc55a81df9c1847587960bec64202be66702456b447c3114d8a9b49fa7bfa08cb032040bc2c1f17411642392abee617e4400fae0a9b67d38702 case-1.5.0.tar.gz"