aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cli_helpers/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-29 22:44:23 -0300
committerAndy Postnikov <apostnikov@gmail.com>2019-06-30 19:17:36 +0300
commit2f6243a80399849b2b17b731bc9f9474ac46c894 (patch)
tree36dc18fd61dd13359b0f9181051299a5229d5cbe /testing/py3-cli_helpers/APKBUILD
parentf6bec3f3514918f0845e3a118fa8a581a17afb28 (diff)
downloadaports-2f6243a80399849b2b17b731bc9f9474ac46c894.tar.bz2
aports-2f6243a80399849b2b17b731bc9f9474ac46c894.tar.xz
testing/py3-cli_helpers: upgrade to 1.2.1
Diffstat (limited to 'testing/py3-cli_helpers/APKBUILD')
-rw-r--r--testing/py3-cli_helpers/APKBUILD49
1 files changed, 12 insertions, 37 deletions
diff --git a/testing/py3-cli_helpers/APKBUILD b/testing/py3-cli_helpers/APKBUILD
index ebdfc98a05..f9c5fd1af1 100644
--- a/testing/py3-cli_helpers/APKBUILD
+++ b/testing/py3-cli_helpers/APKBUILD
@@ -1,57 +1,32 @@
# Contributor: Thomas Boerger <thomas@webhippie.de>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
-pkgname=py-cli_helpers
+pkgname=py3-cli_helpers
_pkgname=cli_helpers
-pkgver=1.0.2
-pkgrel=2
+pkgver=1.2.1
+pkgrel=0
pkgdesc="A helper library for command-line interfaces"
url="https://pypi.python.org/pypi/cli-helpers"
arch="noarch"
-license="BSD"
-depends="py-terminaltables py-backports-csv py-tabulate"
-makedepends="python2-dev py-setuptools python3-dev"
-checkdepends="pytest py-wcwidth"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+license="BSD-3-Clause"
+depends="py3-terminaltables py3-tabulate py3-configobj"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-wcwidth py3-mock"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-cli_helpers" # Backwards compatibility
+provides="py-cli_helpers=$pkgver-r$pkgrel" # Backwards compatiblity
+
check() {
- cd "$builddir"
- python2 setup.py check
- python3 setup.py check
- py.test-2
py.test-3
}
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="6338603deaedbaf4e0cb98303219f5edcd8ccdedc3000cad6d727263f2d2875c8fe3b8ce8b1213d72a7bfa404c24a605458d946868d9d526e7781ff58a139699 py-cli_helpers-1.0.2.tar.gz"
+sha512sums="46f83382800da7e6ba9116df5cd77bf012e14af821a842e73a7f0ddae64e032dd2d00c124b0f0ed18a07226058dbc41185e99ccd7616e971116a57a22ceace51 py3-cli_helpers-1.2.1.tar.gz"