aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-clikit
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 02:35:06 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 16:20:34 +0000
commit9f3675e75f69b8ecb5c660b35268ce0536d7cf33 (patch)
tree621399a35d90727794a3f4471a5ac16e70e3c3b5 /testing/py3-clikit
parent334f910df0a0d434061c7004cba80f27206bb355 (diff)
downloadaports-9f3675e75f69b8ecb5c660b35268ce0536d7cf33.tar.bz2
aports-9f3675e75f69b8ecb5c660b35268ce0536d7cf33.tar.xz
testing/py3-clikit: new aport
Python3 to create beautiful and testable command-line interfaces https://github.com/sdispater/clikit Closes GH-8381
Diffstat (limited to 'testing/py3-clikit')
-rw-r--r--testing/py3-clikit/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-clikit/APKBUILD b/testing/py3-clikit/APKBUILD
new file mode 100644
index 0000000000..27e12f8e71
--- /dev/null
+++ b/testing/py3-clikit/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-clikit
+_realname=clikit
+pkgver=0.2.4
+pkgrel=0
+pkgdesc="Python3 library to create beautiful and testable command-line interfaces"
+options="!check" # No tests on pypi tarball, github uses pyproject.toml
+url="https://github.com/sdispater/clikit"
+arch="noarch"
+license="MIT"
+depends="python3 py3-pastel py3-pylev"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="be274997595a75afa3d3369fcaf32c8a02a6845d23bda37feeb021f9edeb623c65551c52f13098af799b14ca0b247fbb835867a7ec1993ffdef9426f3e03f6cb clikit-0.2.4.tar.gz"