aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-compdb
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-03 03:05:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-18 14:56:53 -0300
commitc9782251778d2c53d5122c71694621b6a9aee6df (patch)
tree5205fa700662118dbad2e8e183161d5aa4872629 /testing/py3-compdb
parentbe82477324cade6a73de6ec9185f9a711a4d7c2c (diff)
downloadaports-c9782251778d2c53d5122c71694621b6a9aee6df.tar.bz2
aports-c9782251778d2c53d5122c71694621b6a9aee6df.tar.xz
testing/py3-compdb: rename from py-compdb
Diffstat (limited to 'testing/py3-compdb')
-rw-r--r--testing/py3-compdb/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/py3-compdb/APKBUILD b/testing/py3-compdb/APKBUILD
new file mode 100644
index 0000000000..3179aadd80
--- /dev/null
+++ b/testing/py3-compdb/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
+# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
+pkgname=py-compdb
+_pkgname=${pkgname#py-*}
+pkgver=0_git20180122
+pkgrel=1
+pkgdesc="The compilation database Swiss army knife"
+url="https://github.com/Sarcasm/compdb"
+arch="noarch"
+license="MIT"
+makedepends="python3-dev py-setuptools"
+subpackages="$pkgname-doc py3-${pkgname#py-}:py3 py2-${pkgname#py-}:py2"
+options="!check"
+_gitrev="7a77fec75c8c562ef6c5046e6b0fe9f944ad5e38"
+source="$pkgname-$pkgver.zip::https://github.com/Sarcasm/$_pkgname/archive/$_gitrev.zip"
+builddir="$srcdir/"$_pkgname-$_gitrev
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ install -d "$pkgdir"/usr/share/doc/$_pkgname/
+ install -t "$pkgdir"/usr/share/doc/$_pkgname/ README.rst
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+sha512sums="f7c08559339dca33739f997fec6151e218b9f208a204b60329f8b5250bed4682d085a61b8c8c4745a3e25d65353c6a06ee4b33954e59dedd5e692024e98015aa py-compdb-0_git20180122.zip"