aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cycler
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 12:39:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:07:09 -0300
commit3e2cefab40b8493364abf1208f9a7f796903e338 (patch)
treef98efdc7edeedec7e31f58dd6a6838e2eb2c01f1 /testing/py3-cycler
parent86466ac13658f30038f5dca852ab3e0de2e58978 (diff)
downloadaports-3e2cefab40b8493364abf1208f9a7f796903e338.tar.bz2
aports-3e2cefab40b8493364abf1208f9a7f796903e338.tar.xz
testing/py3-cycler: rename from py-cycler
Diffstat (limited to 'testing/py3-cycler')
-rw-r--r--testing/py3-cycler/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/py3-cycler/APKBUILD b/testing/py3-cycler/APKBUILD
new file mode 100644
index 0000000000..3367c07135
--- /dev/null
+++ b/testing/py3-cycler/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=py-cycler
+_pkgname=cycler
+pkgver=0.10.0
+pkgrel=4
+pkgdesc="Composable style cycles in Python"
+url="https://matplotlib.org/cycler/"
+arch="noarch"
+license="BSD"
+makedepends="python2-dev python3-dev py-setuptools"
+checkdepends="py-nose"
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+source="https://files.pythonhosted.org/packages/source/C/Cycler/$_pkgname-$pkgver.tar.gz"
+builddir="${srcdir}/${_pkgname}-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 run_tests.py
+ python3 run_tests.py
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir" || return 1
+}
+
+md5sums="4cb42917ac5007d1cdff6cccfe2d016b cycler-0.10.0.tar.gz"
+sha256sums="cd7b2d1018258d7247a71425e9f26463dfb444d411c39569972f4ce586b0c9d8 cycler-0.10.0.tar.gz"
+sha512sums="b7d2ba19861ffaf4dea0444bfe68b5a6264a022d7b3f02c9ff5e5859e3901de12a90f8dc7469e995e09c418515b3df55dbf05a0cfe5368d40790a2c878a74819 cycler-0.10.0.tar.gz"