aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dexml
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-29 23:14:15 +0200
committerprspkt <prspkt@protonmail.com>2019-03-29 23:33:31 +0200
commit40716e362f089ceee0bc2326e0eaaad18c7f186c (patch)
tree93acb450d203918e91eca5ac0395075ca070a290 /testing/py3-dexml
parent365fba1a1026ccd482cd8766cd22480e372352f9 (diff)
downloadaports-40716e362f089ceee0bc2326e0eaaad18c7f186c.tar.bz2
aports-40716e362f089ceee0bc2326e0eaaad18c7f186c.tar.xz
testing/py-dexml: upgrade to python3
- Replace dead url with pypi.org.
Diffstat (limited to 'testing/py3-dexml')
-rw-r--r--testing/py3-dexml/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/py3-dexml/APKBUILD b/testing/py3-dexml/APKBUILD
new file mode 100644
index 0000000000..70af28c1cf
--- /dev/null
+++ b/testing/py3-dexml/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-dexml
+_pkgname=dexml
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="A simple Object-XML mapper for Python"
+url="https://pypi.org/project/dexml"
+arch="noarch"
+license="MIT"
+provides="py-dexml" # for backwards compatibility
+replaces="py-dexml=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+depends_dev=""
+makedepends="python3-dev py3-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="7f7bbb66cdceb38adbc9092a9a159d87 dexml-0.5.1.tar.gz"
+sha256sums="6ba83883ead5cc74ce8198daecc657b60bf9cdb3887b484a92dcde55c10e2cdf dexml-0.5.1.tar.gz"
+sha512sums="b8ac2b9f875ac7cf699eb9ee17adb8678ed8d4a796130bbb60f05431207adb68f490b7a7a41600acbc16a3cc08d55f22d91a13e53fe3d835a322709ee3446c9f dexml-0.5.1.tar.gz"