aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-discogs-client
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-08 21:35:56 +0300
committerprspkt <prspkt@protonmail.com>2019-06-08 21:35:56 +0300
commit5b097ee6e017434a744f45b67dc73e8e3bafb0e1 (patch)
treea33c204a00c3289b8ac108cfc433b10c569af82b /testing/py3-discogs-client
parentd480cd32acb4061aaddb26409855bc6cfa533c14 (diff)
downloadaports-5b097ee6e017434a744f45b67dc73e8e3bafb0e1.tar.bz2
aports-5b097ee6e017434a744f45b67dc73e8e3bafb0e1.tar.xz
testing/py3-discogs-client: add check, modernize
Diffstat (limited to 'testing/py3-discogs-client')
-rw-r--r--testing/py3-discogs-client/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/py3-discogs-client/APKBUILD b/testing/py3-discogs-client/APKBUILD
index f1080abf44..e5cb639a6c 100644
--- a/testing/py3-discogs-client/APKBUILD
+++ b/testing/py3-discogs-client/APKBUILD
@@ -3,25 +3,28 @@
pkgname=py3-discogs-client
_pkgname=discogs-client
pkgver=2.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Official Python API client for Discogs"
url="https://github.com/discogs/discogs_client"
arch="noarch"
license="BSD-2-Clause"
-provides="py-discogs-client" # for backwards compatibility
-replaces="py-discogs-client=$pkgver-r$pkgrel" # for backwards compatibility
-depends="python3 py3-requests py3-oauthlib py3-six"
-makedepends="python3-dev py3-setuptools"
+depends="py3-oauthlib py3-requests py3-six"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-discogs-client" # for backwards compatibility
+provides="py-discogs-client=$pkgver-r$pkgrel" # for backwards compatibility
+
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}