aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-diskcache
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 03:28:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 03:41:42 -0300
commit7bc999e4ba2d0e6a103f06dea147525917a1cc7b (patch)
treeb4e8a353480e3cc3cb797990ef0185de96727071 /testing/py3-diskcache
parent1bb30ad71323bd9acc6a41bd66e93fc565bda9d6 (diff)
downloadaports-7bc999e4ba2d0e6a103f06dea147525917a1cc7b.tar.bz2
aports-7bc999e4ba2d0e6a103f06dea147525917a1cc7b.tar.xz
testing/py3-diskcache: rename from py-diskcache
Diffstat (limited to 'testing/py3-diskcache')
-rw-r--r--testing/py3-diskcache/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py3-diskcache/APKBUILD b/testing/py3-diskcache/APKBUILD
new file mode 100644
index 0000000000..d2d7823cf0
--- /dev/null
+++ b/testing/py3-diskcache/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor:
+# Maintainer:
+pkgname=py-diskcache
+pkgver=2.8.3
+pkgrel=1
+pkgdesc="disk caching implementation"
+url="http://pypi.python.org/pypi/diskcache/"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-diskcache:py2 py3-diskcache:py3"
+source="https://files.pythonhosted.org/packages/source/d/diskcache/diskcache-$pkgver.tar.gz"
+
+builddir="$srcdir"/diskcache-$pkgver
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="d96ac76dfb68cb817febd3f4ed8927a8409c02b13b4112a739528cade40f9a588c732dfc3148392dd12676380c3a2b006ee63b86f30ad70f5d205273003bf23d diskcache-2.8.3.tar.gz"