aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-distorm3
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-24 18:18:27 +0300
committerprspkt <prspkt@protonmail.com>2019-06-24 18:42:38 +0300
commit4bebc39821c311b9c6e1e11166d57736b0e12836 (patch)
treeda636e1520f2493c9dc5577ea211a530ef233cc4 /testing/py3-distorm3
parent9c1280dbe099775b089bd67c5fe7fb9127bb64a2 (diff)
downloadaports-4bebc39821c311b9c6e1e11166d57736b0e12836.tar.bz2
aports-4bebc39821c311b9c6e1e11166d57736b0e12836.tar.xz
testing/py3-distorm3: clarify license, modernize
Diffstat (limited to 'testing/py3-distorm3')
-rw-r--r--testing/py3-distorm3/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/testing/py3-distorm3/APKBUILD b/testing/py3-distorm3/APKBUILD
index 14603327fc..ff46e13221 100644
--- a/testing/py3-distorm3/APKBUILD
+++ b/testing/py3-distorm3/APKBUILD
@@ -4,25 +4,23 @@ pkgname=py3-distorm3
_pkgname=distorm3
pkgver=3.3.4
pkgrel=1
-pkgdesc="The goal of diStorm3 is to decode x86/AMD64 binary streams and return a structure that describes each instruction"
+pkgdesc="Disassembler Library For x86/AMD64"
url="https://pypi.python.org/pypi/distorm3"
arch="all"
-license="MIT"
+license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
-source="https://github.com/gdabah/distorm/releases/download/v$pkgver/distorm3-$pkgver.zip"
-builddir="$srcdir/${pkgname/py3-/}-$pkgver"
+source="https://github.com/gdabah/distorm/releases/download/v$pkgver/$_pkgname-$pkgver.zip"
+builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-distorm3" # Backwards compatibility
provides="py-distorm3=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}